Unable to receive mails using SMTP

Dear All,

I am trying to send a mail from my gmail to the same using the SMTP. I am using Port 587 and address is “smtp.gmail.com” I am not getting any errors the bot executes properly but no mails is retrieved. I need assistance on this. I even tried enabling the less secure apps and after that as well it did not work.

Hi @Deekshith_Lakshminarasimh,

Welcome to Uipath Forum :grinning:

Give the port number as 465 and Also give the server plase as SMTP.gmail.com

Omkar P

@Deekshith_Lakshminarasimh, Hi and welcome.

just to be sure. you not sending and receiving from the same email address?

Hi @SenzoD,

I am afraid so yes I am sending and receiving from the same email address.

Is that a problem?

Deekshith L

Hi @Reddy_Paluri,

I will try the same and will let you know whether it works or not

Thanks for the help !
Deekshith L

Hi, @Deekshith_Lakshminarasimh,

I don’t think is a problem using same email. As long you correct username, password, port, should be fine.

That is just to answer your question from this Post?

Be Safe!

@Deekshith_Lakshminarasimh, No, it shouldn’t be a problem, I just asked out of curiosity.

Have you tried changing the port to 465, and also check the spam mailbox, also check if SMTP TLS/SSL required is set to yes.

and since you already tried to make less secure apps enabled i just cant think of a possible reason for mails to not come through.

Hi @Deekshith_Lakshminarasimh,

Now we got it. I was having trouble so this is what I did just today:
•Turn On: Less secure apps access, very important: “Log Out and then Log In”
•Port: 465
•Server: smtp.gmail.com
•Secure connection: auto

Be Safe!


Many thanks for the solution, I was able to receive the mail from my own gmail after changing the port Number of SMTP to 465. I just have one question though why is that SMTP with 587 did not work earlier? Because other than that I did not change anything in the sequence

Dear @SenzoD,

Thanks for the help , I am able to receive the mails now to my gmail now.

Stay safe! :slight_smile:

Hi @Deekshith_Lakshminarasimh,

Good question, that best I can think of is that if you notice 465 would apply to google/gmail but looking 587 would be for Microsoft Outlook. I believe they have their own way to treat security through those port numbers. I do use the 587 but when using MS Outlook and also use 465 when use Gmail.

Be Safe!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.