Unable to read pdf file

pdf
activities
p_notaproblem

#1

Hi, I’m not able to read any PDF files using the Read PDF activity. Then error received is as shown below.

I tried them with Read PDF with OCR as well, and the error received is

Please help.

[UPDATE 20/04/2017] - I tried in a different system and the activity works perfectly. Is there any way I could re-install the UIPath.PDF.Activities?


#2

Looks like there is a problem in installation of the PDF Activities Pack. Try reinstalling the Package ‘UIPath.PDF.Activities’


#3

Not sure but can you check the pdf properties…is it Actrobat Reader?

Looks like its a 32bit/64bit issue.


#4

I am not able to uninstall it. The UIPath.PDF.Activities is not found in Installed tab, but in the Available tab with a green tick. There is no uninstall option for these activities.


#5

I tried 2 different PDF’s. What should I check in the properties? What do you mean ‘is it Acrobat Reader’? The extension was .pdf.


#6

Nevermind I don’t think it is relevant to the issue, but I want to check if Opens with is Acrobat Reader or someother program

or


#7

It’s the second one. Using Adobe Reader. BTW I can still open the same file in a different system. So shouldn’t this be an issue with the UIPath in my system? If that is correct, is there any way I could re-install just the PDF package UIPath.PDF.Activities?


#8

I have an option to uninstall the PDF Package. Do u have an option to uninstall other packages ? Are you able to do operaions on Excel/word etc using any other external Packages?


#9

Hi Vinutha,

I re-installed UIPath in the system completely and then installed the PDF package again. But even that, did not solve the issue. Is there any alternative way in which I could solve the issue?


#10

As the same activity works in other machine, there seems to be a compatibility issue of UIPath in your machine. Can u try reinstalling the UIPath again by troubleshooting the program and disabling compatibility check?
Right click on UIPath installer Package -> Properties -> Select the Compatibility tab -> Click on ‘Run compatibility troubleshooter’. In the pop-up window You can either click on test the program which reinstalls the UIPath or click on Next to save settings to the installer file using which you can manually reinstall the UIPath.


#11

Hi Vinutha,

I had sought the support of UIPath and it’s now clear that the issue is because, some of the services which are used by UIPath is being blocked by the intranet of our company. The IT team is currently working on it and will be rectified soon. Thank you so much for your time. :slight_smile:


#12

Hi RPA_noob,

We are trying to read a pdf file and there was an error logged - mentioning GPO. Is that what happened in your case and what did the IT team say regarding access rights?


#13

Dear All,

How to read bookmarks,hyperlinks in pdf using uipath, Please help me with an example.

Best Regards,
Vijaya


#14

Hi rman,

I really don’t remember if I saw something like GPO in the error. I believe I didn’t as I have sent the complete error screenshot above. And I’m not sure what the IT team did, but they said it’s because UiPath did not have rights to access PDF Reader installed in the machine due to some security issues.

Thanks,
Midhun


#15

Hi vijaya,

When you read the pdf file using activity, are you getting those links in the result?

Thanks,
Midhun