Unable to push project to Github

Hello,
I am unable to push my code to Github as it shows Authentication Failed Error. Tried access with Token and SSH as well.Still shows same error. Please Help.

Do you want to create a new remote repository from UiPath or clone/checkout from Github?
Did you create a personal token? See: Creating a personal access token - GitHub Docs

Did you select the correct ssh or https url from github?

Please show us the steps what you did and where you get stuck.

I have cloned and committed the project.
but when tried to push to Github it was showing the error.

Yes, I tried both SSH and Token method with correct URLs …still shows the same error.

How did you clone the project? via SSH or HTTPS?
Are you able to push from commandline? (just to test that the repo and token is correct).
Did you set the github personal token like this?
chrome_Dcaw4dUK4x

i just tested without any issues.

  1. create a (private) repo in github.
  2. create the personal token and paste it in notepad
  3. upload an example xaml file to the repo (otherwise uipath starts whining on my end that i cannot clone the repo).
  4. open uipath studio > settings > team > enable git
  5. open uipath studio > start > clone repo
    UiPath.Studio_xgwRSCdHco
  6. open the main.xaml > do some changes and save the file and commit and push the changes
    UiPath.Studio_NF7H3KkYz5

Commit and push > success. So far no issues. So i’m really curious what is causing the authentication failure.

My opinion: After 1,5 years that git was available in UiPath i still don’t use it. Once in a while i try it again, but every time it messes up my repo’s, so i still use git clients or CLI to update the projects to my gitlab or github server. So if you run into problems like Can't switch to other branch from Master you know you’re not the only one ;).

2 Likes

Hey @jvanmarion …i really appreciate and thank you for the suggestions.
I just realized was pushing the code in wrong folder.
Thank you so much

Glad you solved the issue. Please mark some answer as a solution one, so others can see that the issue has been resolved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.