Unable to publish on Orchestrator

Hello everyone,

Until today I never had any proble to publish my project on Orchestrator but today for one of those I have the following error message : Error: Publish of Process project to Orchestrator failed. An error has occurred.

On the same machine, I tried to do the same think with other project and that’s worked so it’s not a connection issue.

Do you know how can I fix this issue please.

Please find details of logs in attached file and I use 21.4.4 version.


2023-03-27_UiPath.Studio.Project.zip (24.5 KB)

You can try to update/downgrade your activities and see again what happens.

Hi @stary,

I did it on a previous version, but that induce a regression on my DU activities so on all my process, as you can see below. That’s the reason why I would like to avoid that.

@stary ,

Just to complete my previous post, I update packages but I should to modify some things in my process. However, I have the following error message : “System exception at initialization: Attempted to access an element as a type incompatible with the array. at Source: Create Document Validation Action”
So I can’t to creante activity in Action Center. This is an other issue but the update of the packages does not solve my publishing problem, I did the test.

If you or anything else have an idea to resolve these issues.

Hmm… I would try debugging and adjusting process to the updated activities. Probably type of some variable/argument used in this activities doesn’t work anymore.

Hi @stary,

The process run well in debug.
To resolve the issue of publication on Orchestrator I create a new REFramework, copy paste all variables/arguments and invoke workflow and copy/paste all dependencies… in this new project and that work good.
However my issue due to update packages is not resolve that’s why I keep older version.

What about different processes? Does publishing works for them correctly?

You haven’t mentioned whether you are using Cloud (Community/Enterprise) or Private (On-Prem/Cloud).

First thought if you can publish one Project but not another is to look at the file size of the created nuget package. If you are using a Private Orchestrator instance you could review the Service Logs to reveal the actual error message in the Windows Event Viewer.

This has come up a few times for our developers are they temporary drop files in to the Project Space and forget to remove / exclude them before publishing, or inadvertently include a growing collection of screenshots that are unused, etc.

1 Like

Hi @stary ,

Yes I can publish correctly all my processes correctly,

Hi @codemonkee,

Thanks for your suggestion. We are using On-Prem version.
We already checked if it was file size and it was not that. That was confirmed after that I recreate the REFramework from scratch and add all workflows, variables… to publish my process and that work, the size is the same as the previous one.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.