Unable to open projects after switching to enterprise version

I installed the StudioX 2020.6-beta 93 version when I began taking an online UIPath course using a trial license because I did not have access to my company’s enterprise license at the time. During the class I wrote 50+ automated tests.

I have now installed my company’s enterprise license for StudioX, however, I can no longer open any of my project or workflow files. Error message states the project/workflow is incompatible w/ StudioX profile. You can open it in Studio and fix the errors.

I don’t have Studio. Any ideas how to fix these files?

Hi, welcome to the forum!
StudioX and Studio are the same program, to change the profile follow this:

what version is the enterprise studio?

The enterprise version is 2020.4.1. It looks like I’m in Studio when what I was using is StudioX. I uninstalled, ran the platform install w/ my license key, and I wound up with a different interface. I again tried to open my StudioX projects w/ the same error.

I went into settings to look for a method to switch the profile to studiox, but none is present.

Should be under settings- license- change profile. Can you check?

All I see when I go under license and profile is View or Edit License and nothing related to Profile. (Screenshot uploaded:

).

I go into View or Edit License and receive a “Let’s Activate” dialog:

I click to Add License Key receive a prompt to add license key (Screenshot uploaded:

.

I enter my StudioX license key, click continue, and receive prompt that license has changed and do I want to restart. I say yes, UIPath restarts, and I’m still in the same condition as before.

basically you did a project in 20.6 studiox and was not able to open it in 20.4.1 studiox/studio, right? that should work.
can you please attach one of the projects?
and is also odd that you don’t find the sections to switch between profiles in 20.4.1 should look like this:

Nope, I do not see those profile options at all.

I tried to attach my zipped up project folder, but the system says new users are not allowed to upload attachments.

Looking at the project.json file, could it be that some of the resources are not present?

{
“name”: “Switch”,
“description”: “SwitchActivityChoicesExample”,
“main”: “Main.xaml”,
“dependencies”: {
“UiPath.Excel.Activities”: “[2.9.0-preview]”,
“UiPath.Mail.Activities”: “[1.9.0-preview]”,
“UiPath.System.Activities”: “[20.6.1-preview]”,
“UiPath.UIAutomation.Activities”: “[20.6.0-preview]”
},
“webServices”: ,
“entitiesStores”: ,
“schemaVersion”: “4.0”,
“studioVersion”: “20.6.0.0”,
“projectVersion”: “1.0.0”,
“runtimeOptions”: {
“autoDispose”: false,
“isPausable”: true,
“requiresUserInteraction”: true,
“supportsPersistence”: false,
“excludedLoggedData”: [
“Private:*”,
password
],
“executionType”: “Workflow”
},
“designOptions”: {
“projectProfile”: “Developement”,
“outputType”: “Process”,
“libraryOptions”: {
“includeOriginalXaml”: false,
“privateWorkflows”:
},
“fileInfoCollection”:
},
“expressionLanguage”: “VisualBasic”
}

zip the project and change the extension to txt , you should be able to upload.
also i know that after few posts even new users could attach files.

Attaching zip of project folder w/ extension changed to txt.

UIPath_Project_Folder.txt (19.5 KB)

Looking at your project.json file, you can tell under which profile the project has generated - in your case, this “Development” (meaning Studio), not “Business” (meaning StudioX). I believe you got things mixed up, this is a Studio project, not a StudioX one, so you need to open it with Studio.

“projectProfile”: “Developement”,

I opened the project with studio and you only have a send SMTP Mail message which is not a StudioX activity. Also dependencies from the project are particular to Studio : excel, mail, system and UIAutomation.
If it would be a StudioX project it would have by default excel, mail, word, system and UIAutomation.Next and send smtp mail would not be visible in studiox.
i think you confused from the first place and you started with studio to creat your projects and after that you switched to enterprise license of studiox.
studiox looks like this:


did it look like that when you first created the projects?

No, there was a debug menu as well, and it did not have the Activities down the left. If what I had was in fact Studio, then how do I switch back since I have no profile option?

Yes, debug menu appears only in Studio.
If you don’t have the option to switch between profiles as i showed in previous photo from a few posts above it means you are running now an enterprise version with only studiox license.

Thank you for your help. I received an updated license file and I can not toggle between the two profiles.

1 Like