Unable to Install SAP connectors

Hi, I am not able to install the SAP connectors. can you please guide

@loginerror

1 Like

Hi
@balkishan
I tried to reproduce by installing this package in my studio
2018.3
it shows the same error and i hope it must be due to that the package requires some prerequisites or is depricated
Cheers @balkishan

1 Like

Thanks for your quick reply bro, But sure there must be a solution for this.
Request to @loginerror @Pablito @ovi can you please help on this. why it’s not installing

@lakshman @HareeshMR @Lahiru.Fernando @samir @Dominic can anybody reply on this

3 Likes

Please check documentation of this package:

The 32bit (x86) .NET 4.0 Variant of the SAP Connector for Microsoft .NET 3.0 (NCo 3.0) is a prerequisite for this activity pack. This connector also requires the Microsoft C++ Runtime DLL version 10.0 (this is contained in the Microsoft Visual C++ 2010 Redistributable Package).

Important!
Please note that the SAP Connector for Microsoft must be installed in the Windows Global Assembly Cache (GAC) to work properly. This can be done by selecting the appropriate option during the installation of the SAP Connector.

I think this might be problem here.

4 Likes

Did you get any idea on this bro, Please help if you have any idea

1 Like

Hi
I hope we need some prerequisites to be installed in our machine to get this package installed that includes like
SAP Connector for Microsoft .NET 3.0
Microsoft C++ Runtime DLL version 10.0 (this is contained in the Microsoft Visual C++ 2010 Redistributable Package)

–and for the first one to download
https://support.sap.com/en/product/connectors/msnet.html
and for the second one
https://www.microsoft.com/en-in/download/details.aspx?id=5555

once this is installed being prerequisites as per the document

i hope installing this package will work
Cheers @balkishan

1 Like

when I open this link it ask me for the Username & Password. And even I am not able to Signup?

1 Like

i hope we need a SAP licensed version for this buddy
Kindly check once with your admin team on this @balkishan
Cheers

1 Like

Yes bro, Even I created an account on sap.com but when we download this software this account is not working it redirect us to another portal where asking the username and password.
image

1 Like

yah thats what, i hope we need a license to install it
image

Kindly check with your admin team to gets the rights and install it
then we can surely get that package
Cheers @balkishan

1 Like

Yes, I will ask them bro

1 Like

Microsoft Visual C++ 2010 is already installed on my PC.
image

1 Like

Hi I downloaded the prerequisite software but still SAP BAPI Package is not installing.
Can you please help before installing SAP Connectors it was showing the same error after installed the SAP Connectors it shows the same error.
image

SAP Connector Installed
image

@Pablito @Dominic kindly help

@Palaniyappan & @Pablito can you please help me on this issue. As you shared me the two links for downloading the software, I installed the prerequisite software. Even I installed the SAP connectors but still I SAP BAPI Package is not installing.
Same error it’s showing when I try to install it.

1 Like

I wonder why didn’t
Though i haven’t used it, this is what is been mentioned here
is that a licensed version buddy @balkishan

@Pablito Kindly help us on this

1 Like

After installing the prerequisite software atleast SAP BAPI Package should be installed, but it’s throwing an error message while I downloading the package.
image

@loginerror can you please help me on issue, why it’s not installing the package even I installed the pre-requisite software SAP Connectors and Microsoft Visual Redistribution x64. Last two days I am trying to install the same package but couldn’t install.

I think I’ve found solution for this issue. Somebody had similar problem and this is step-by-step guide how to solve it:

1 Like

I already his steps, but facing the same issue. Same error I am getting while downloading the package.

Hmmm my last option is to ask @StefanSchnell (sorry for disturbing) I saw he’s doing miracles with SAP :slight_smile:

1 Like

@Pablito

Hello Pawel,
thank you for bringing that post into my attention.
Best regards
Stefan

@balkishan

Hello Balkishan,
you installed the wrong version of SAP dotNET Connector, use x86 version and not x64 version, as you mentioned in your post from the 1st of August.

Temp001

Deinstall x64 version and install x86 version, try it again and let us know your results.

Temp002

Best regards
Stefan

3 Likes