Unable to insert logs to elasticsearch

I have an orchestrtaor running as PAAS on azure cloud and i want to store robot logs to elasticsearch. To achieve the same I have created the elastic stack wtih kibana as available on azure marketplace. I am able to access elasticsearch via load balancer and kibana externally on browser.

I tried sending some messages to elasticsearch via powershell as mentioned in this post. Elasticsearch - no index from uipath and index does get created in elasticsearch which is then correctly reflecting in Kibana. So I think there is no issue in setting up elasticsearch and its connection with KIbana.

I have done below changes in the web.config file of orchestrator.

  <target name="robotElasticBuffer" xsi:type="BufferingWrapper" flushTimeout="5000">
    <target xsi:type="ElasticSearch" name="robotElastic" uri="secret" requireAuth="false"  username="" password="" index="${event-properties:item=indexName}-${date:format=yyyy.MM}" documentType="logEvent" includeAllProperties="true" layout="${message}" excludedProperties="agentSessionId,tenantId,organizationUnitId,indexName" />
    <target xsi:type="ElasticSearch" name="serverElastic" uri="secret" requireAuth="false" username="" password="" index="serverlogs-${date:format=yyyy.MM}" documentType="logEvent" includeAllProperties="true" layout="${machinename} ${message}" />
  </target>
<rules>
  <logger name="BusinessException.*" minlevel="Info" writeTo="businessExceptionEventLog" final="true" />
  <logger name="Robot.*" writeTo="robotElasticBuffer" final="true" />
  <logger name="Monitoring.*" writeTo="monitoring" minlevel="Warn" final="true" />
  <logger name="Quartz.*" minlevel="Warn" writeTo="eventLogQuartz" final="true" />
  <logger name="*" minlevel="Info" writeTo="eventLog" />
</rules>

But it does not seem to work. Logs from robot are not getting inserted in elasticsearch.

Please suggest what can be done next in order to get this working.

@loginerror , @ovi please let me know if anything is missing.