Unable to Identify Elements in Machine Readable PDF

pdf
p_solved

#1

Hi all,

I am attempting to read specific elements off a machine generated PDF document, using the Get Full Text activity.

I have attached the pdf file for reference.

The activity works as intended on my own version of UiPath (2016.2.6232), however when running the same workflow on a secondary laptop (also 2016.2.6232), UiPath cannot identify any individual elements, only the full screen - as if it’s a scanned pdf.

The version of Adobe on both systems is Adobe Acrobat Reader DC, version 15.023.20056. I’ve also applied the same Accessibility settings across both applications.

One obvious difference between the laptops is the operating system - my system is Windows 10 Pro (where the workflow is operating as expected), while the secondary laptop is on Windows 10 Home.

Has anyone else come across this issue?

Regards,
Daniel

Br8866.pdf (14.4 KB)


Unable to read nor copy&paste PDF generated by PDF printer
#2

I know it sounds silly…could you please update your GDI driver? @adrian @Gabriel_Tatu


Selecting PDF Elements
#3

there is a known issue where pdf files are not detected sometimes, dev is still investigating as its not 100% reproducible.


#4

@Badita that’s actually a very good suggestion…

So, I’ve been able to replicate this issue on two different laptops now… updating the display driver did solve the problem on one of the laptops, but not the other!

To update the driver, I went to Settings > System > Display > Advanced display settings > Display adapter properties

Would it be a good idea to update all available display drivers via Device Manager instead? @Adrian @Gabriel_Tatu


#5

Hi @Badita @Gabriel_Tatu

Hope you guys are well. It’s been a few weeks since I last looked into this issue, but I think I have an idea on what may be causing the problem…

Do devices that function as dual laptop/tablet have problems when automating in UiPath?

I’ve replicated the issue on a Lenovo Yoga and Lenovo ThinkPad - both have the ability to flip & become a tablet, so I’m wondering if this somehow interferes with UiPath’s ability to read the interface?

I’ve disabled the touchscreen functionality, this has made no difference.

Also, the problem is not confined to PDF’s, it also impacts regular desktop applications too.

Regards,
Dan


#6

solved in 2017.1


#7

hello dlp 1980, the activity “Get Full Text” is not working at my side: i had an emty text field


#8

I was able to identify element using Adobe DC . But I uninstalled and tried to identify using Adobe Acrobat Pro. Unfortunately,it does not identify the elements.It just identify the PDF as a whole.

I have downloaded the lastest UiPath 2017…

Please help


#9

I face the same issue - can’t identify individual elements in PDF - Acrobar Reader XI + UiPath 2017.1

Cheers


Unable to activate buttons on Adobe Acrobat XI
#10

Hi!
I had the exact same problem. I tried installing various pdf-readers with no luck. However, I was finally able to solve it by adjusting some settings in Adobe Acrobat Reader DC. This is what I did:

  1. Click “Edit” in Adobe Acrobat Reader DC and choose “Preferences”
  2. In the Preference-window, choose “Page Display” under Categories to the left
  3. At the bottom of the Page there is a section called “Reference XObjects View Mode”. There is an option there called “Show reference xObject targets”. This option is probably not set to “Always”. Set it to “Always” and click ok.
  4. This solved the problem for me and may do the trick for you as well. GL

#12

Awesome! Thanks


#13

Thanks Bro :slight_smile: