Unable to get filter to work using filter data table

Hi,

I am trying to use the filter data table activity to return rows based on column value “Guided Self-Serve” in a column in my excel sheet. I’ve specified in filter wizard to keep rows where column4 (the column where “guided self-serve” is found so with my sample data file provided only one row should be returned. However when I run the project it keeps delivering the full unfiltered data-set of 3 rows. Where have I gone wrong? :frowning:

Any help would be hugely appreciated.

Regards,

Jeff

Sequence.xaml (9.0 KB)

Procurement WIP Download File.xlsx (13.3 KB)

Guided Self-Serve File.xlsx (14.6 KB)

Please make the below changes to the workflow:

  1. Remove the Range from your “Read Range” activity. Leaving it blank will always account for any number of rows in your file and you won’t have to change it again and again in your code.
  2. Please select the “Add Headers” option so that when the bot finds the very first row of data, it would treat it as column names.
  3. In your Filter Data Table activity, please change the name of the column to the actual column from your name. This is necessary because we used Add Headers option before.
  4. While using Write Range activity, please check the “Add Headers” option again so that the column names are also added along with the filtered data.

Try this and let me know if you still have any doubts.

1 Like

Thank you so much! Really appreciate this.

Regards,

Jeff

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.