Unable to get file extension after copying to a folder

I have multiple files like excel,pdf files, while i’m trying files from folder to other folder but after copying files those extension are displaying different and unable to open them.Please provide solution.

Hi PraveenM1,

Which activity are you using to move files, for both “Copy File” and “Move File” activities in the “Destination” property you have to include the file extension. For example if you are moving an excel file “UipathProjectInput.xlsx” from folder “C:\Projects” to “C:\Projects\MyProjects” then in “Path” property you have to give “C:\Projects\UipathProjectInput.xlsx” in “to” property you have to mention path including extension like “C:\Projects\MyProjects\UipathProjectInput.xlsx”.

Thanks,

copy file activity

did you tried the solution of including file extension

I have tried selecting hide file extension and unselect check box but still after copying files to destination folder still unable to open copied files.

Send us error screen shot and your workflow screen shots

These files i am trying to copy into other folder



but after validaitng excel or pdf are getting blank

Use move file activity to rectify this error🙂. Then reply what is happen.
Thank you.

tried with move file too but the files are not in readable state after moving.

Can you please check whether the destination path is getting framed properly with extension?

I suspect that extension is not being framed while copying. Pls check and revert back for further help.

Dude i need screenshots of “Copy File” file activity properties. even after adding extension also it is not working ???

my output path

my copy file actvity

in previous screen shot you had assigned an variable called “Extension” and i dont think so you are adding it in your “Destination(String)” like".xlsx",".pdf"

Where are you adding the file extension here?

check this

i am not adding file extension could you please suggest me where to replace.

You are getting the extension when copying . But i dont think you are adding in the file name of destination path . That seems to be the issue.
Please add the extension and check .

To Test it

print the destination path in message box and check whether path with filename,Extensions are correct

…+StrTime+Extension

Add Extension after StrTime

1 Like

okay.