Unable to find and click on the text

Hi everyone,

So I am making a program to create an invoice based on the delivery order, I am able to fill all the entries but I am stuck where I have to find and select a DO number (when there are more than 1 DO, since if it is one then the first one will be selected by default, no issues there), I tried click text, click OCR text, OCR text exists and nothing seems to work, the usual error (when I add the click text options inside my web recordings/native citrix recordings) is The method or operation is not implemented

image

This is how the available receipts appear in a tabular form based on the invoice, and clicking on the row or Packaging slip number (DO Number) will select that Deliver order. This is where I am stuck, if the correct DO is selected I have no issues ahead of this step as well.
Please see if anyone can help me with finding a workaround for this. I am using Native Citrix and Web recording since I don’t have much knowledge on their differences.

@Pratishthit
I am a rookie too, I try to help if possible.
Can u share the xaml file?

Sorry @sulungcayadi I have some credentials also in them which I cannot share, but ask me what would you like to know. There are only web recordings or clicking buttons and filling fields, and the click text also goes in there, but not working.

@Pratishthit
I can understand more or less your problem however with my current skills it is required a lot of “trial and error” before can solve your issue with such limited information.

My advise:

  1. To check uipath foundation training and check related with Citrix recording and Try/Catch operation
  2. To use flowchart flow and break each process into sequences that you can test independently especially the section where system found a multiple DO existed.
  3. To add logs to output pane from each sequence to check variable result/value

If you could not solve it then you could consider to get consultant/ professional to help you.
Hope above advice is workable. Happy automation.

dear ,

you need to specify more about your issue such as the environment (web ,desktop,citrix …) ,and the selector you had or if there is recording will be much better , to see exactly the issue and try to check the logo or if there is any error !

Thanks for noticing the issue, I did actually go back to the project and tried troubleshooting it myself, was playing around with the OCR settings and got a working condition.

I used Click OCR Text, using Google OCR with Invert selected and Scale set to 7 or 10.

I hope this can help someone else too.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.