Unable to Click on "Font" option under "Format" Menu in Notepad

Edit: All three solutions given below worked perfectly. But I have to Mark only one as solution :slight_smile:
I used Attach Window activity to click on “Format” menu option in NOTEPAD without using any Automatic Recorder and it worked as expected.
image

But then when I use Attach Window activity again to further click on “Font” option, I am unable to do so as the 2nd window(Submenu of Format) disappears. Below is the expected screenshot of the same but I couldn’t get that.
image

How do make sure I can click on Font option ?

Hey @Ashish_Verma,

If you have succeeded with the click on format option then send the hotkey f it will open up the font window and in that case you do not need to click on Font.

As per my understanding, I think that will work only in case of automatic recorder. Here I am not using any automatic recorder. Simply using Attach window and Click activities in series to perform automation. Kindly correct If I am wrong.

You can use the activity Send hotkey from the activity pane using drag and drop approach and use it anywhere in the workflow.

When you are clicking on the format option the next activity should be send hotkey with f as the key to send and you are done

1 Like

Hi,

In attach window’s ‘Do’ sequence, replace ‘Click’ activity with ‘Send HotKey’ activity with key as ‘f’.
This will give same results as clicking ‘font’ button.

Let me know if more info needed.

3 Likes
  1. Attach Window activity, use Indicator to Select the window
  2. Inside the Attach Window activity use Click activity to click “Format”
  3. Inside the SAME Attach Windows activity use Click activity to “invisible” element “Font”.
    Use F2 to pause recording, click Format, and after 3 seconds click Font
3 Likes

This works :slight_smile:

I tried as seen from screenshot below.
Is this correct? How to use Attach Window Activity now?

In fact you do not need to do an attach window but anyway this seems ok and it should get the work done.

1 Like

Thanks a lot. It worked perfectly. :slight_smile:

Thanks a lot. It worked correctly. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.