Unable to automate process: no selectors available, and type into is not working without a selector

selector
studio

#1

Hello all,

I’m trying to run the program “hp connected backup installer” and automate the installation of this software by simply clicking on “OK” and “Next” buttons.

I tried to use the “Click” activity, but when clicking on “indicate in screen” and selecting the “Next” button, then UiPath will not give a selector as a result.
This issue is happening with any other activity, as for example “Click Text” and “Send hotkey”.

And I also tried to use the “Send hotkey” activity without a selector, which should work, as the focus is on the installation window I’m trying to click. So if the focus is on that window, why is the hotkey activity not working? No clue…

There are also other screens during the installation process, where I have to type text, and also that case I’m not able to use the “Type into” activity. Even with the focus on the window, the “type into” activity won’t type anything…

I already searched for similiar issues within the forum, but didn’t find anything.

Does anyone know what is happening and how it can be solved?

Thanks in advance.


#2

Add activity attach window (HP window) and then try send other activities inside the box.
For other activities do not make any selectors.


#3

@pllo2ptk, also did that, without any success.


#4

What about click image?


#5

with click image you also have to indicate a selector, meaning that it also won’t work.


#6

No, you do not have to


#7

Yes, you have.
When you use “Click Image”, when you click on “indicate on screen”, then you select the image you want to click with the red cursor, right?
And after selecting the image, a selector automatically appears.
So I’m also unable to use “Click Image”, because after selecting the button on the application, no image and no selector appears.


#8

No, you do not have to do that. I am sure of this.
Do not click just select the field where the mouse has to click.
So select the whole button (DO NOT CLICK ON IT).
After this delete selector if there any.


#9

@pllo2ptk, as I’ve written in my previous email, I’m not able to select anything when clicking on “indicate on screen”…


#10

I know that you cannot indicate on screen, but you can always take the image from the screen.
In this case hold mouse when you want take the image of the button.
It works like a snipping tool.


#11

@pllo2ptk, it does not work:
“So I’m also unable to use “Click Image”, because after selecting the button on the application, no image and no selector appears”


#12

Hi @jcab Use Click image Activity it should work , decrease the accuracy for better results, Or use relative click if you don’t find a valid element to click.
Click image should definitely work.


#13

Try to make a screenshot and then make Click Image on this :smiley:


#14

I think that you still wnat to click the button, not select the image with the button.


#15

The UIElements of the window are simply not recognized.

And the “send hotkey” and “type into” should work without selector, when the focus is on the window. But it also is not working…


#16

Stop looking for UiElement, start looking for the image.
Do you know how to scrape image from screen?
You are still trying to get selector from application which is not possible. Do this with image.

have you passed RPA academy? If not, do this now.


#17

Yes, I am UiPath certified.
Thanks for your help, but all what you said has already been tried.

What I will try later is making a screenshot and trying to click on that screen shoot.

Furthermore, this is only one of the issues. Because I’m really unable to type into many of the fields in the installation window, because there are no existing UI Elements.


#18

You can use image relative -> where you find anchor and click the field.
THis is very similar to citrix environment.
Yes, this is possible to do also with UiPath.


#19

@jcab
Run UiPath Studio as Administrator and then u can get selector in such scenarios.


#20

You can take a screenshot yourself via Paint or something and simply upload the image to the Image Exists activity. Also you can erase the selector in the activity so it won’t have any selectors.