UiPathPack Azure Pipelines Integration is Broken

The latest version of the UiPathPack integration, 2.4, has broken all of my Azure pipelines. The bug is listed in the release notes for the new version (Packaging libraries that included namespaces with periods through the UiPath Pack task failed) - a criteria that will include almost all official UiPath namespaces since nearly all of them include periods. In fact, setting my pipeline to verbose logging shows that the actual failure is occurring when trying to add a UiPath dependency:


The error is that “an item with the same key has already been added” but that particular key only appears once in the verbose log.

My pipelines last ran successfully on Friday using version 2.3.1504174, and are now failing today with version 2.4.1786427. I’ve tried rolling back all changes in my projects made in the interim, to rule out any of my own updates, with no luck.

I have many new updates that I need to get published via this pipeline so that they can be used by my other projects. Is there a configuration I can include in my pipeline yaml to force the integration to use the previous working version rather than the new broken verison? I tried rolling back to Version1 of the package, but that also failed because it is no longer compatible with the newest versions of UiPath.