UiPath Tableau Connector extension error on Tableau Server

I get and error message when using the UiPath Connector Tableau extension on a published Tableau workbook. In Tableau Desktop (2021.1) I’m able to configure the extension and to execute the linked process on our UiPath Cloud Automation platform. However, when I publish the dashboard to our Tableau Server (2021.1 on premise) I get the error message " tableau.uipath.com refused to connect.

If there is anyone that has already worked with the UiPath Connector on Tableau Server? I would gladly appreciate any help or tip to solve this.

Hi, @paul.hoeffer could you help here?

Hmmm…I’m not sure. Richard Wagner is the PM for Tableau and would be a better bet, as there have been changes to this since I last worked on it.

@robert.wagner - Hi, please help :slight_smile:

Hi @rgerst, thank you for your message!
This is a known issue and we are working on it!

I will update this thread once we have a solution for it!
I apologize for the inconvenience!

Thanks for your patience,
Robert

Hahaha @RichardWagner to your service :heart:

Hi @robert.wagner ,

Thank you for you reply. I’m looking forward hearing from you.

Regards,
Ralph

@rgerst we made some changes and it worked for me now. Can you please check if you are able to connect?

@robert.wagner

Unfortunately no change, the extension does not load on Tableau Server.

@robert.wagner

Maybe this helps:
Tableau Shared Widgets v9.6.0
DataCatalogShared.js:304 Data Catalog Shared v11.3.3
angular.min.js?669b24fd7da25a8bab04:127 Possibly unhandled rejection: undefined
(anonymous) @ angular.min.js?669b24fd7da25a8bab04:127
vqlweb.js:57 [Report Only] Refused to evaluate a string as JavaScript because ‘unsafe-eval’ is not an allowed source of script in the following Content Security Policy directive: “script-src * blob:”.

a @ vqlweb.js:57
vqlweb.js:44 Tableau Shared Widgets v9.6.0
vqlweb.js:63 [Report Only] Refused to evaluate a string as JavaScript because ‘unsafe-eval’ is not an allowed source of script in the following Content Security Policy directive: “script-src * blob:”.

(anonymous) @ vqlweb.js:63
chromewebdata/:1 Refused to display ‘https://tableau.uipath.com/’ in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.

@rgerst thank you so much for sharing I will forward this to the team!
I hope I can come back soon with a solution!

@robert.wagner any progress on the topic?

Thank you,
Ralph

Hello @robert.wagner, apparently another customer is having the same issue. Would it be possible to confirm this is an issue and if there will be a fix for this? Thank you.

@rgerst unfortunately there is no solution yet. I will update you as soon I have an ETA.

@sergio.bentim yes this is a known issue in Tableau Cloud environments and we will fix this.

@robert.wagner we are using Tableau server on-premise but UiPath cloud orchestrator.

@sergio.bentim and @rgerst: Unfortunately, as it looks like this cannot be resolve on our end.
I reached out to Tableau for further technical support and guidance.

In some environments there is additional configuration effort required. Maybe you can talk to your Tableau team and ask if they ever encountered this with other products and if they were able to resolve this?

https://community.tableau.com/s/question/0D54T00000CWequ/javascript-api-error-refused-to-display-in-a-frame-because-it-set-xframeoptions-to-sameorigin

https://community.tableau.com/s/question/0D54T00000C5R2mSAF/refused-to-display-httpswwwgooglecom-in-a-frame-because-it-set-xframeoptions-to-sameorigin

https://kb.tableau.com/articles/issue/Blank-Screen-and-Error-Refused-to-display-URL-of-View-in-a-frame-because-it-set-X-Frame-Options-to-SAMEORIGIN-When-Loading-an-Embedded-View

I will update this thread as soon I have further details.

Hi guys, FYI.
I got a response from Tableau and they said we can solve this by using Embedded API v3 .

Right now I am trying to find out what this means for us. It looks like we have to update our app in order to make this work.

I’ll keep you posted!

Robert

@sergio.bentim and @rgerst
I need to inform you we were unable to resolve the problem with Tableau Cloud Dashboards until now and unfortunately it does not look like we will be able to provide a solution for this in the next few months.

So as of now you will only be able to use this Connector in Desktop clients.
We added a comment in our docs stating this fact now.

I am very sorry for the inconvinience and I will update this thread as soon we are back in the Tableau Cloud again.

All the best,
Robert

1 Like