Uipath studio is getting stopped

I am running my process in RE Framework.

After first transaction complete , it start processing second and in the middle to second transaction ui-path studio is getting closed.



Any idea what is causing this issue?
FYI- I am using Enterprise Edition licensed version


Hi @md.ahtesham

Could you please use the “Copy to Clipboard” button and paste here the error logs? It would help.
Also, which version of the Studio are you using and what happens in the process you are trying to execute? :slight_smile:

sorry for late reply,

Please find more details :


Message: Job Invoice Status Update stopped due to unexpected process termination!

Exception Type: System.Exception

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Exception: Job Invoice Status Update stopped due to unexpected process termination!


I looked around and it seems like there might be a lot of possible causes. Could you please contact our Technical Support for more assistance?

Please provide them with as much information as possible, including the output of our Diagnostic tool as explained here:

Naturally, it would also help if you could provide a sample project that causes the issue (if plausible).

If you feel like it, you can also try this dirty solution posted here (if the issue is caused by some broken files):

Hi @loginerror is there any fix (clean one) for this in version 2016.2 ??? I am facing this issue since last 3 days some how i have avoided the read range activities in which case it usually got stuck but now its for every random activity …i am majorly getting it after Copy file activity…

although the dirty fix solutions works fine i am concerned about its robustness and dosent seem to be correct way of doing things i hope you understand and can help me for the same

@badita @ovi can you please help around this?

Hi @rahuls

If it worked, I wouldn’t worry. It was probably due to some files becoming corrupted. If Studio recreated those files without an issue and it is working right now, it should keep working.

@loginerror it is not !!

it works for the first time when you delete those two folders ,

but it fails in the next attempt to run the same bot.

However i don’t want to keep using delete folder method is there some normal solution for this? or may be the root cause for this ??

@aksh1yadav @ovi @badita looking fwd to your inputs on this …

Interesting - this means that the corruption happens upon the bot run.

Could you test with an empty project that simply logs a few variables to the console?
It would be nice to see if the files get corrupted after any bot run or only after this particular workflow run.

I was able to figure out why it was crashing for me.

For my process - i was using kill process activity which was taking memory consumption to 98-99% . So, i removed that activity .
Other alternative are there for this to handle.

  • give some delay after kill if you are using so that memory consumption comes to normal stage.

Other issue which causes this crashing is :

  • Read range activity where you might be reading very big file.


@loginerror figured it out !!! finally

It was not due to file being corrupted rather the problem was that i was passing data table as an argument inside for each loop

the loop ran for first 3 4 records and showed the error !!

so just to tried out i exempted passing that Data table and it worked out just fine !!!

though i am not able to understand how came it ran successfully for the first 3 4 records and then broke out due to memory (i guess!!! ideally it should do garbage collection for those passed arguments and free the memory but somehow its not doing that)

@md.ahtesham yes this error is there due to following reasons as per my knowledge
1> Read range which contains huge data
2> large writerange text
3> passing large datatable as an argument

Thanks everyone for your inputs and suggestions !! glad to be part of this community :slight_smile:

Hi @rahuls i am facing memory out of exception. Is that your issues same and if that resolved, how have resolved that issue.