Uipath Studio Community 2022.4.1 project cannot be started (compiled) after something has changed and save

The project cannot be started (compiled) after something has changed in it and the project has been saved. Project compilation and publishing freezes. You can see the progress bar that stops. To compile or publish a project, you need to Close Studio and restart the entire project, then Launch or Publish.

If I make any changes and save it, the project will not be published and will not start.

The disadvantages of the previous version were removed because the previous version did not work at all. But nothing can be tested with this one either.

Additionally, it does not work:
Invoke Workflow File, more precisely: Import Arguments and Open Workflow.
It stopped working the earlier version and still doesn’t work. No arguments could be imported.

1 Like

Hello @r.rydzewski ,

Did you made any changes to the UiPATH studio settings? Did you tried reinstalling a fresh copy of studio?

I don’t remember for sure. But in the previous version of Studio it was even worse and I think I changed some settings because I couldn’t compile the project at all because I got Error. I have had several workflows. And that was probably what was causing the Error. Then when the last version came out, I made an Update. And you can’t test normally since then. It does not work as I wrote, mainly Start (compilation) and publishing.

1 Like

Hey @r.rydzewski

What’s the version of studio please ?

Also some screenshots will give more idea !


Last Version Studio Community. 2022.4.1.

I changed this selected setting from error to warning


this is how it manifests itself. If I change something in the project, I will add, delete and save. This project cannot be started. It checks the mistakes of eternity.

If I close this window (I click cancel and the cross), I can make new changes to the project, etc.

But I won’t run the project 100%. I have to close Uipath and restart, open the project and it will be ok. The project will start. Blank Play.
But if I change anything about him again. The project will not start. In my opinion there is some problem with validation of errors. The project is big. It contains a lot of sequences and other activities.

I can expand the arrow and select Play Debug, but it will be the same, Project won’t start, it stops checking errors.

this is my setting

The bar stops in the same place. I will add that the same project on the previous, previous version worked fine.

When restart and run project Run ok…

Checked on 2 different computers. Same design. Same version. I will add that in the same project I have a test Sequence, it contains test solutions and few different activities, and so there is no problem with running

Zrzut ekranu 2022-05-10 084515

Next Problem is: Error Publish of Process project to ORCHESTRATOR

Additional NOTORIC problem - when the project is already working after restart, I have such a message again when publishing the project.

There was once, but it was very, very stinging. Now I have it in a row, for example 10 times and I never manage to publish the project. A disaster.

And there is no solution to this problem?

This indicates that you have a folder (usually the screenshots folder) that has a lot of data in it, making the project too large to publish.