Macro issue - Cannot run the macro. the macro may not be available in this workbook or all macros may be disabled

Hi guyz, Is any one have the solution for the above stated Macro issue .
I have multiple macros running in processes.And in continuously facing this issue from last 2 weeks.
Though the macros are available in the workbook still it is saying macro not available or visible.
I tried so many solutions like :

  1. Adding delay between open Excel and execute macro.
  2. Updated UiPath macro excel package.
    but nothing worked.

Pleas help.:pray:

Hi @Anjali_Rani

Have you enabled the macros in excel?


nothing worked, i tried with all. please help me out of any other solutions :pray:
Just to highlight this is not occuring everytime, suppose I run code 10 times so 6 times it will occur. This is very randomly occuring.

Hello @Anjali_Rani Welcome to the UiPath Community Forum

Please check following things in macro :

  1. Excel settings are preserved throughout else launch excel as admin and then alter the settings provided by @lrtetala.
  2. Check any syntax issues in Subroutine or Function in macro
    3.Try manually running the macro : Excel → View Macro → Run