UiPath Orchestrator APIs not working since Cloud Platform Release

Thanks for your help!

I changed the url to <https://platform.uipath.com/ 2 /> as requested (I tried https://platform.uipath.com/2/ too), but it did not work. Now I get a message “Could not find a process named [my_process_name] in [my_environment]”

I’m waiting for your update.


Hi @marcelojrfarias

Could you check out this post of me for more reference on how to use the new Cloud API?

It contains a zipped project that will generate you all the necessary things. It is basically a project version of the guide from here:


When I try to access the provided URL (https://platform.uipath.com/swagger/ui/index#/), it gives Account Not Found error. When I access the URL, it prompts login and then gives the error. However, if I just login to the account, there aren’t any such issues.

Could you kindly advise on this?


Hi @deepak.naidu

Please first navigate to your Orchestrator and then append this to the address:

Your link will look like so:



Thanks, it works now.


It doesn’t work for me.
I’ve tried the oauth method with mobile:

Or the by pasting the swagger link into my orchestrator


I’ve tried multiple iterations (using my personal account name, email, removing default from default from CastGroupDefault, admin, empty


hey guys, can someone please tell whether it’s a problem on my side or UIPath?
I spent 2 months on a project, the API is the only step missing in my whole process

hi @danielvianna @loginerror @deepak.naidu @kensho76

the uipath cloud platform have different ways to Authentication, go to the following link to do the authentication https://docs.uipath.com/orchestrator/v2019/reference#consuming-cloud-api

and the rest of the api are same https://docs.uipath.com/orchestrator/v2019/reference#about-odata-and-references

Happy Learning😊
Achal Sharma


@Achal_Sharma Achal do you have currently a project with working api that uses the api to trigger orchestrator?

1 Like

Check here:

The project contains all you need. The 04. Get License.xaml is the sample API request to get license info from Orchestrator :slight_smile:

1 Like

I will check loginerror, thank you!

1 Like

I moved my request to the other post. I still have the same issue. It’s not a problem generating the keys and tokens but the actual authentication itself to activate orchestrator

1 Like

Hi @KamalSaran,
How to find the tenancy name in the orchestrator?


1 Like

Hi @Vashisht

The service is the tenancy name in the orchestrator, if you are using enterprises orchestrator. If you are using community version orchestrator then use the follwing step:-
Community Version Orchestrator API

Cheers :slight_smile:

Achal Sharma


Maybe it can be useful for someone.

I have started to use the Orchestrator API. I was facing the “Invalid credentials, failed to login” error despite of using the correct credentials (same I use log to platform.uipath.com/).

Aparently, at least it was my case, when I changed (weeks ago) the password because I had troubles to login, this was updated only for the platform but no for API (https://platform.uipath.com/api/account/authenticate).

I tried the old password and it worked!

As it occured to some people, I had problems to find find the Tenant Name. You can check it in “My Profile” (click on up-right corner (the orange circle) >> MyProfile)


Hi All,

I wanted to follow up on this thread as the Authentication updates to our Cloud platform are now live and are significantly simplified.

The new method gives each user a key, which can be used to generate 24-hour access tokens that may be revoked or refreshed at any time. Here is the documentation to help you understand where to find these tokens and the API calls that use them:

Orchestrator Documentation

Postman Collection

Note that this method is only used for https://platform.uipath.com. On-premise Orchestrators can still use Tenant, Username, and Password for authentication.



I also still facing the same issue with Orchestrator APIs since 18 Jun 2020.

Is issue resolved from your side?

Any update in this regard?


1 Like


I have posted reply on old post. I am not facing any issue with login but having the APIs issue.

Need update in this regard only.


1 Like

Hi @manmohan.singh

Feel free to create a new topic in the #manage:orchestrator category with more details about your issue.

For the reference, the latest version of our Cloud API documentation can be found here:

1 Like


I was using the API with NTLM authentication which is the windows credential to log in and after the new orchestrator update this stopped working. THe orchestrator I’m using is the enterprise edition. Could you tell me what changed with this update which made this to stop from logging with NTLM authentication ?

Diogo Nunes

1 Like