UIPATH Orchestrator API result: {"message":"An error has occurred.","errorCode":0}

queue
api

#1

Good Morning Community:

I am dealing some problems with the orchestrator API, trying to DELETE a queue item by id, with the UiPAth HttpRequest Activity.

Previously of course I authenticate to get the access Token, it goes well, and after that I execute the GET action over the queue on order to confirm that it goes well:

https://[orchestrator_url]/odata/QueueItems(ID), with the GET method. It returns the json with the queue Item and it goes well.

In the same activity, if I change to the DELETE method, as indicated in the API Guide, I obtain the next response:
{“message”:“An error has occurred.”,“errorCode”:0}

I get the same error with more actions of this type, but not always: I can create new Schedules via API in example, but not queue item or assets.

Am I missing some parameter, or permission?? Any help would be appreciated…


Error code: 0
#2

Hi Rosario,

I cannot tell from the error message what is the problem exactly(it’s work in progress to trigger meaningful error messages).

But my first thought is with the Delete permission on Transactions on the user in Orchestrator(the ones in Roles). Can you please check that first?


#3

That seems to be in the good way, thaks!
I will check how to edit the roles, and tell you.
Again, thanks a lot


#4

Another idea that crossed my mind is to check if the item you are trying to delete is In Progress.


#5

Thanks again… No,the problem seems match your first option, as I am building a proccess that is being executed in a Robot, so at last ( from my point of view) the orchestrator is accessed via API from a robot, which has Robot role options assigned, so it wont be abled to perform certain methods (i have checked which ones and it’s a match) even when I authenticate as admin…

So my challenge now, I guess, is giving my robot a role with more actions allowed. I am working in finding the point to do that since it seems to be a default configuration…

Anyway, i will have to keep in mind your second option, because in case that I have success in this challenge, for sure i will face it in the future, so thanks in advance!


#6

Hi again… I’M still dealing with this issue…

First of all, happy new year!

I am authenticating as a user with all those items checked. like an admin user, but even with that i get errors when i try to perform operations like deleting an item of a queue. Is like if the API checked over the ‘Robot’ default role instead the one i have created…

Not completely off topic… do i need to update something to interact with the 2017 API version? Because i am checking my functions and responses and I think I am missing something, when i try to peform something of the new version, i get errors as if those functions didnt exist, and when it goes well, the responses i get are according to the old version…

THANKS again for reading me. This would be amazing to enhance my system.


#7

Just to clarify my steps… I make a ‘GET’ HttpRequest Activity over the queueItemDto with an id, and I get the information about the queue item properly.

If I change the method to ‘DELETE’, i get again the ‘{“message”:“An error has occurred.”,“errorCode”:0}’…

I have all the checks activated for the user that I use to aunthenticate… Am i missing somenthing?? I’m out of ideas… =(


#8

Hi Rosario,

I’ve tried with Swagger UI for Orchestrator CE and it gives the same error with response code 500. I’ve passed this to QA team for further investigation. I’ll get back to you with a specific answer(or bug confirmation) as soon as I hear from my colleagues.

Thanks for your patience!


#9

Really thankful @ovi, thanks a lot !! Happy new year =D


#10

Happy New Year! :tada:


#11

@rmadrigal So, i got an answer.

Delete method doesn’t work. I managed to delete an item using POST method - DeleteBulk.

deleteBulkParameters:
{
“queueItems”: [
{
“RowVersion”: “string”,
“Id”: 0
}
]
}

Let me know if this works for you.


#12

Too bad that I can only click the ‘Like’ icon one time…

THANKS A LOT @ovi, this is exactly what i ineeded. Aldo, i didnt know about Swagger UI (as i am a newbie with uipath ) and i find ir really useful !

Mi queue item is deleted succesfully, this is great, the alternative wes having a little complex (not complex, but unuseful) algorithm to manage my processed queue items. Thanks Again!


#13

Hello again! Not completely for the same target, but related to this topic…
I am tryin to filter my API query , done over JobDto, by its ‘Key’ field.

Following the API model: [orch URL]/odata/Jobs?$$filter=Key eq ‘[job key]’

then i filter over other fields of the JobDto it goes well (like $filter=Source eq ‘Manual’), but when I try to filter by key I get our favorite error (ha ha)… is this a special type of field?

Thanks in advance…


#14

Hi @ovi,
I am trying to create assets by using HTTP Request, but i am getting response code as 500 please help me out regarding this. If you have any sample process to create assets by using HTTP Request. Please attach it.

Regards,
Mahaling Patil