UiPath Orchestrator API : Authentication

Thanks @Teodor_Hoaghea :relaxed:

i had used similar steps but the HTTP request has error stating Password parameter already declared. I am able to see result in Preview Window but in UI Studio getting error

Might be …not sure… you are passing it in header section as well and in parameter section as well… …just check it :slight_smile:

Regards…!!
Aksh

1 Like

Hi @aksh1yadav

do you have a HTTP Request Builder example using the authentication access token from the UiPath Orchestrator to get information from the Orchestrator? Everything I try results in an error that says I’m not signed in.

Many thanks

David

Hey @david.spriggs

I have script and will share once will find it on my system :slight_smile: and allowed to share the standalone implementation. Let me know if you will not be able to achieve it still i will share :slight_smile:

i guess @Susana you can share that example script shared. i hope you remember :slight_smile:

Well after hitting the Authenticate api you will receive an authorization access token and that will be valid for 60 minutes.( previous 2016.2 api version info but guess will be same)
then you have to pass the token in header with following manner

Authorization: Bearer xxxxxxxxxxx

Authorization is a name attribute in Header Section
and Bearer xxxxxxxxxxxx is the value in header section

xxxxxxxxxxx - represents the access token.

then you will not get the above error.

Regards…!!
Aksh

1 Like

@david.spriggs, Find below the solution link shared by @Susana,

Require guidance in Orchestrator API

CC : @aksh1yadav

Regards,
Dominic :slight_smile:

1 Like

CC: :rofl: @Dominic

Regards…!!
Aksh

@aksh1yadav, Ha bro just wantedly :wink:

Regard s,
Dominic :slight_smile:

Many thanks

Orchestrator Login mode is Windows.
I am use URL https://xxxx.xxxx.xxxx/api/account/authenticate to authenticate.

It does not works.

any idea would be helpful.

Hi

when you say it doesn’t work do you get an error? If so could you share this here. Also which version of Orchestrator are you using?

Cheers

David

I ma using version 2017. Error Code is 500 and says Login Model is null

Have you tried the project example Require guidance in Orchestrator API uploaded in this thread? Maybe give it a go and post your results.

David

Hi @aksh1yadav I am getting invalid credentials while trying http request,but im able to login using platform url. Could you please help me

Hey @Dinesh_S1

Just Cross check you are passing tenancy name as well in parameters and if you are passing already then make sure about spaces.

Regards…!!
Aksh

Hi @Dinesh_S1

Welcome to our UiPath Forum! :slight_smile:

Please see the Cloud API Authentication guide here:
https://orchestrator.uipath.com/v2019/reference#consuming-cloud-api

1 Like

Orchestrator API authentication for windows user. please share any workflow

Hi I’m uipath and API new user. I try to use authentication API but I get an error, I think it’s because of tenancyName, I don’t understand very well, which information should I put?

Hi @Richmond_Eki_EDOUKOU

Welcome to our UiPath Forum! :slight_smile:

Please go over this guide here:
https://docs.uipath.com/orchestrator/v2019/reference#consuming-cloud-api

Hi @loginerror thanks so much, I tried and it works fine.
Thank you

1 Like