UIpath Executor has stopped working

image

Hello, I am facing some error. UIpath UIpath.Executor crash randomly when i try to pull datatable row into the website.

Workflow exception
Message : Job work stopped due to unexpected termination!
Exception type : Exception

I did some testing and found that if i am extracting the data using an IF condition to get the row that i need, it will crash randomly. Without the IF condition, i am able to extract all the rows and put it into the webpage.

Does anyone come across this issues before?

2 Likes

I am also facing the same issue. Can anyone help me out with this?

@zhongyong11 did you get any solution for this?

Hi @Narmatha7296

Could you create and share a blank project with faulty behaviour? Please try to recreate the error with a public website, for example a simple google search. We will investigate more.

1 Like

I am getting this error in one particular project which is playing with excel and Web Application. The excel contains around 250 rows and i am processing each data in the web application. It is not occurring in the same place, randomly it is throwing.
I have published same code to the OR and it is working fine. When I am trying to run the code from studio, I am getting this error.

kindly help me out with this issue

2 Likes

Hi @loginerror

I am also facing this error, however, I narrowed it down, it occurs every time at the activity “Excel Application Scope”. The Event Viewer gives the following about the error:

Is there any solution/workaround to this? Note, this does not occur intermittently, but rather every single time the robot executes.

Studio Version:
Studio 2018.3.1 - 10/17/2018
Community Edition
EXE Installer

Microsoft Windows 10 Pro 64-bit
.NET Framework Version 4.6.2

2 Likes

Hi @Abu

Are you by chance using very big excel data set? It is a known issue when you try to load an Excel file that contains a lot of information into 1 Data Table.

A workaround would be to split the data and load half of it into 1 data table and the other into the second one.

Could you maybe attach a sample project with the faulty Excel file (if possible)? We are on the lookout for files that can reproduce this issue.
(please replace any confidential data in the file with some placeholders, as long as the project/file will keep on throwing the error :slight_smile:

3 Likes

Thank you for your swift response @loginerror.

My excel set running is 9KB. Do you think the error could be related to the “.Net version”, or the excel package itself?

The sample file: Test.xlsx (8.3 KB)

Update:
I uninstalled my version of Excel on my machine, loaded another version, it gave me another error (The RPC server is unavailable (Exception from HRESULT: 0x800706BA)). This was then solved using @nesachdeva workaround on this thread RPC server unavailable.

Thanks for the help @loginerror :+1::slightly_smiling_face:

1 Like

Is there any fix/ update as we moved our project developed on Version 2018.2.3 to Version 2018.3.2.

We are also facing the same error.

In this project we download the excel file from web QLS(Query logging system) and process that case in SAP and upload back that Excel file(11 KB) file to web CRM application only.

@loginerror @Abu

Awaiting reply.

Regards
HJ

Good day @Harshit_jain

Two questions,

  1. Have you tried using the delay workaround?
  2. Have you tried re-installing the excel application or using a different version on the robot machine? What version of Excel are you currently using?

Hey @Abu,

Thank for the suggestion.

It was already running on Version 2018.2.3, As we got a new installer 2018.3.2. We have to move it to production with the new version.

Also we are now running it on VM with MS Office 2016, where in local it was deployed with MS-Office 2010.

Hi all,

I am also facing the same error Uipath.executor has stopped working and we are not able to identify conclusively the reason behind the error. We are using a lot of excel files during the execution of the process which involves invoking multiple workflows, but after each workflow we are using the Kill process activity to close all the open excel files so that they won’t hinder the process. But inspite of this , we are facing the UiPath.executor error. Can someone please suggest a solution for this.Eagerly waiting for the reply.

Thanks,
Arjun

1 Like

Hello Arjun,

Could you please check the version which you are using.

Also check for the dependencies.

Regards
Harshit

Hello Arjun,

Have you solved this problem? I am facing the similar issue with yours. If you know the solution, please kindly share with us. Thank you!

1 Like

This can happen when upgrade package to upper version. Like Core Activity and Excel activity.
I have faced this in the time of migration from development to UAT environment where we had different activity packages. Try downgrading it.

If this happens particular with one excel file thrn go for the Invoke code.

1 Like

Hi All,

I’m also facing the same issue. “UiPath.Executor has stopped working” and it’s occur in different process/sites/application in my project.
Sometimes it occur while processing with Internet Explorer, sometime with MS Word and sometimes in MS Excel.
I’m also using delay, as a matter of fact it running now 5x slower than manual process but still having this issue.
Any idea why is it occuring? By the way I’m running it with version 2018.4.5

TIA!

1 Like

Any fix for this?

what is your particular case, that error was solved in previous versions

This error appears to occur when dealing with Excel files with too many records. In my case, the error occurs when trying to write a DataTable with 57k of records using the WorkBook Write Range, which causes the memory to collapse and generate an exception of type System.OutOfMemoryException

The solution for me was to use the Write Range activity of Excel Application Scope, however on some occasions the problem appears through the DataTable. I have read that this problem is oriented towards the memory consumption of the machine where the process is executed and its architecture (if it is 32 Bits or 64 Bits) if it is 64 Bits when the memory consumption exceeds 50 % of available memory, then the process generates exception. If the machine is 32 bits you should not present this error. Downgrade the packages did not work for me.

Error-SystemOutOfMemory