UiPath Apps Public Preview

Haven’t you heard? UiPath Apps is now available in Public Preview! Check out the full UiPath Apps Preview Announcement on our blog.

Overview

UiPath Apps is a cloud based low-code application development platform that enables you to build and share enterprise grade custom applications that deliver engaging user experiences. Using UiPath Apps, you can quickly build custom business applications that connect to data in any underlying cloud or on premises system using the power of automation.

Apps built with UiPath App Studio provide rich controls for data access and update as well as conditional logic for complex business needs. The underlying UiPath RPA platform provides advanced workflow and business logic capabilities to automate your entire end to end business process.

Read more…

Quickstart guide

  1. Log into your Automation Cloud account on https://cloud.uipath.com (or if you don’t have an account, register here).
  2. Click on image in the navigation bar.
  3. Check out the tutorial on Creating Your First App.

Documentation

Check out the full UiPath Apps Documentation or jump into some useful topics highlighted below:

Watch :clapper: Engage with Robots

Since nobody actually likes reading documentation… Go back and watch Engage with Robots from DevCon (Day 2, Session 18) to see UiPath Apps and UiPath Data Service in action.

FAQ

Some frequently asked questions. More will be added here over the course of the preview as they come up.

Didn’t UiPath already release ‘Apps’? :thinking:

Action Center was initially launched+licensed as “Apps” in 2019 and was renamed in 2020. UiPath Apps (and App Studio) are new to the platform!

Is it available on-premise?

During Public Preview you can connect to your on-premise orchestrator from within App Studio. Need more here? We would love to hear from you, please send us your feedback.

Can I export apps to be run natively on my desktop or mobile device?

UiPath Apps are Progressive Web Apps (PWAs), which means they can be “pinned” to your device’s homescreen and can be launched stand-alone, giving users a near native experience without actually having to download or install anything.

If you truly want a native experience, read packaging an app as a client.

Reporting Issues and Feedback

The Product Engineering team members will be engaged closely in reviewing all of your feedback and providing additional help or clarity.

We can’t wait to see what you build :rocket:

From all of us on the UiPath Apps team, thank you for your participation and feedback!

28 Likes

Blown Away! Im gonna get started with Apps

5 Likes

Hi @evan.cohen
I connected the flow to Attended Robot, but when tried to run the process by clicking on button, getting this error.

What version of Studio/Robot are you using? It looks like you don’t have the JS Add-on for Robot. Check out the Apps prerequisites in the documentation for more info.

I’ve been developing features like Apps (using Orchestrator APIs) in our internal web portals but, this is just great! Can’t wait to see a whole BPM tool inside UiPath :slight_smile: . This will be great for better User Experience, Traceability, Compliance and so many other aspects. Congratulations for the release. Is it possible to embed (iframe) an App in an existing web application?

I like the idea of having one stop shop for RPA projects. It would be great if there’s a way to add “tabs” with documentation (PDD, User Story, User Guide & etc) and Iframes (Kibana Dashboards in my case)

2 Likes

This Apps Are Really Awesome.
here i want to compare the values by using string methods like starts with ends with contains in If Condition
AND
Need to do Substring also for the variable
Can you please let me know how to do it

1 Like

Hi UiPath Apps Core Team,
You are doing Great Job, Appreciate your Work in UiPath App Studio .
Small Help i need , here is i m facing few issues in If Condition

UiPath App - IF CONDITION - is it Issue OR am i doing Wrong ?

1 Like

Great questions and feedback here, thanks folks!

@rdgagp
While it’s not “officially” supported in Preview you should be able to iFrame apps today, so long as you’re using a compatible browser. Also, thanks for the suggestion - totally agree that a one stop shop for RPA projects would streamline things.

@sudheern
You’re not doing anything wrong, you’ve found a bug. We’re actively working on a fix for the click and drag issue you saw and icons appearing in the resource panel when they should not.

:rocket:

2 Likes

Hi @sudheern: There is a workaround for click and drag. You can double click on the specific property to get added. Hope this helps.

2 Likes

Thank you very much @Venkata_Rajendran , Double Click is working fine , Appreciate your Quick Response

1 Like

Thanks a lot @evan.cohen , Appreciate your Quick Response

1 Like

Hello @evan.cohen
I am facing the problem while running the process from Apps


My Studio version is 2020.10.0-beta-320
I am using UiPath Assistant version 2020.10.0
I am using community edition and I created a folder script in my project folder which has UiPathRobot js file.

2 Likes

Hey @Parth_Doshi:

Can you please try the following?

  1. Please ensure your robot is connected to the same orchestrator which has the processes which are referenced in your App.
  2. If point1 is configured correctly, please follow the below steps to ensure Robot JS is working fine.
  • Open Task Scheduler
  • In Task Scheduler, click on task scheduler library
  • UiPath Robot JS - right click and run

Kindly let us know if the above steps still doesn’t solve your issue.

2 Likes

Yes it solved the problem.
Thank you so much @Venkata_Rajendran for your quick response.

3 Likes

Hey @shubhiyadav: Can you please try the fix provided in the link below
UiPath Apps Public Preview

Wow, UiPath is a Hero in RPA World. Thanks :+1:

1 Like

HI UiPath Apps Core Team,

May i know how to display Data Table in UiPath App from UiPath App Studio

i want to display all columns (how to configur Columns)

Still i m facing same issue , Any Help Please

HI UiPath Apps Team,
You Done Awesome Job, UiPath App Studio is Very Nice, Non Programmers can Build Web Apps and they Can call Processes , Really Super Job Team.

i have small doubt , can you please help on it
i m trying to do nested drop down list like (Country DDL to State DDL)
both has to call two different Processes but for First DDL i configured only one process, but when i perform it is calling both processes even though i m not configure second process
Please Let me know , am i doing wrong or is it a Bug


Thanks Team

Issue Video