UIPath Advance Training Assignment 1


#1

I am trying my hand at UIPath advance training assignment 1.

  1. I am stuck at extracting the data in ACME website after clicking on work items tab post login.
    I have tried both Data Scraping and Screen scraping in trying to get the details of WIID,Type,Status etc of each of the items in all the pages.
    I am facing the issue where I am unable to scrape more than 1 sheet at a time. I have used different selectors for next page link but still unable to get the complete data. I can get individual table data from any page but cant get all page details in the data table. When I include all pages I get empty data table. However for individual pages I can get data. I have also set maxnoofresults to 0.

Could you please help me with this?

->Selector I am using to navigate to next page (tried both the below ones)

<html app='chrome.exe' title='ACME System 1 - Work Items' /><webctrl aaname='>' tag='A' />

<html app='chrome.exe' title='ACME System 1 - Work Items' /><webctrl css-selector='body&gt;div&gt;div&gt;div&gt;nav&gt;ul&gt;li' idx='10' tag='LI' />

Thanks,
Vinay


#2

Hi! have to set the maxnoofresults of extract table to 0?


#3

Yes I have used 0,100 and 200 all the numbers I tried


#4

Try using * instead of Work Items in the selector! that Might help!
Other than this next link selector seems to be fine…


#5

Tried that option as well but no luck. I am able to navigate to all the pages but the problem is data table remains empty. Could you please share xaml file only for this particular step?


#6

If you have enabled spanning to multiple pages then you don’t need to use another activity for just moving to a new page. Try data scraping again and when it asks for multiple pages click yes and indicate the next page element.
I will post the xaml in a while.


#7

Make sure the default value of data table variable is assigned to New System.Data.DataTable!


#8

Thank you Rishabh. It is working now. Used the default value you mentioned.


#9

Awesome :slight_smile:


#10

Hi,

I have used Firefox to implement this assignment. It was working fine but after clicking on Update work item button,the process stops. It neither types any comment nor it changes the status of the work item. I think there is probably some issue with firefox. Can anybody suggest me something please? Thanks in advance.


#11

Hi @SHAISTA,

Try a workaround navigate directly to Update Work Items page instead of opening a new window that would work I am sure. Let me know if you still face the issue.


#12

Thanks @lakshman. It worked!!:smiley::+1: