Can not extract Datatable in ACME System 1 Page

Hi. I’m working on Assignment1 Level3 now.
But I can not get the datatable from System1 webpage. I couldn’t select whole table, when I indicate element in browser using Extract Structured Data Activities like below pics.

If I chose just one data or dragged the whole tables to choose, it didn’t work properly then came errors out. So I have look into this forum to solve this problem. somebody said type it into selector. So I did then it said “Validate”

but when I’m trying to test it. it was stopping at Extract Structured Data…
how can I solve this? Plz help me out.

Thx in advance. (200.8 KB)


Indicate Column Headers like Actions or WIID etc. and then try once.

Hi @lakshman
I selected “WIID” Column and then tried it again. it came same errors below this.

ExtractDataTable: Cannot find the UI element corresponding to this selector:
System error at initialization: Cannot find the UI element corresponding to this selector: at Source: ExtractDataTable


Do one thing.

Click on this DataScraping option indicate Column Headers and follow.


Hello @Chris_Kim
You Just Select any Row after that one message box Appear to ask to “are you want select whole table or not” then you press yes.
its automatically extarct whole table.


1 Like

I did what you said. but it also doesn’t work
and then NextLinkSelector was disappeared


Please find the attached workflow for your reference.

Just open ACME site IE browser and go to Workitems page and run this workflow.

ACMEDataScraping.xaml (7.4 KB)


Thx for helping me

Actually, I got it how to do this one. So it worked scraping and moving next page. but all of sudden, it doesn’t work to go next pages.
I looked into selector it said invalid…what should i do?

and also I did it on Chrome browser. should I change it to IE?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.