UI Path scripts are failing when RDP is disconnected


UI Path scripts are failing when RDP is disconnected , but working fine when RDP is connected. Please suggest workaround

Steps to reproduce:

Current Behavior:

Expected Behavior:

Studio/Robot/Orchestrator Version: 2016.2.6379

Last stable behavior:
Last stable version:
OS Version: Windows Server 2012
Others if Relevant: (workflow, logs, .net version, service pack, etc):

Are you 1)minimizing or 2)closing the RDP client?

If 1) please try to set RemoteDesktop_SuppressWhenMinimized in the registry:


2.Please follow this.


Thanks ddpadil . I am actually disconnecting the RDP . I got hints from other posts that we need to use Orchestrator . Please suggest if there is a way using the UIPath studio Pro?

1 Like

process always start in windows like systems does, that means no ui. And that why i crashes.

When you make a process the only thing you have in main.xaml is an activity - Launch Workflow Interactive, and that point to another xaml file where all the code is in. This activity ensures that the code always runs in the windows mode that have ui. and then it works.

And you can do this without an Orchestrator


Thanks ddpadil . I will try this .

1 Like

Did this work? I’m still having trouble with this. I’ve made the registry edit, I’ve added to ‘-file:“c:/***/main.xaml” --monitor --rdp’ to the uirobot.exe shortcut but the robot won’t work when I minimize the remote desktop window. I’ve also tried the launch workflow interactive which didn’t work. This is quite a big problem when we’re talking about back office robots.

1 Like

I assume you have gone though all the above content and forum too.
if still facing issue then please let us know whats the error?


We’ve tried everything we’ve found online. At least OCR doesn’t work when the remote desktop window is minimized, which is a problem since it’s the only way the robot works on one part of the program we are automating.


What I have seen that activities with Send Window Message check box works well when RDP is disconnected.
Get Text, Set Text, Send Hotkeys, Attach window, Excel, Word , PDF, API etc activities are also working fine in disconnected mode. I use Invoke Interactive Workflow with screen coordinates to invoke the main file.

Activities like Take Screenshot, Click Image, OCR are unreliable in disconnected mode.
You ll need to find some alternative method to make thing work in disconnected mode. Try using hotkey Ctrl+A, Ctrl +C to get the text from the screen(if possible) instead of OCR.