UI Path fails to work when launched in interactive mode


#1

I’m in the process of automating a Oracle Forms application and the automation process has to run on a remote machine. The script works fine as long as I’m connected via Remote Desktop and run it. When I run the script in interactive mode after I disconnect the script misbehaves and stops. The issues that occur are random but mostly happens when a flow that involves a pop up shows up, where I get an exception due to a control that I’m looking for not being present, but the point is none of these happen when I’m connected to the system and when I watch the script run.


#2

Does your script starts the Remote Desktop session?
If is a pop up dialog is causing your script to exit pre-maturely, perhaps you can put an Error Handling Try-Catch, in the catch ‘Find Element Exist’ then handle it, since you state is random/inconsistent occurrence.

Help me understand. Is your automation script runs well in Studio but fails in UIRobot?


#3

Sounds like the same situation I ran into a while back. You need to start the automation process from Task Scheduler or command line. When you disconnect RDP you also disconnect the Windows UI and UiPath can’t do anything with the UI after that.

Try executing this from the command line
"C:\Program Files (x86)\UiPath Studio\UiRobot.exe" /file:"\Main.xaml" /executor /monitored

This might be helpful:


#4

Mostly when a process fails it puts a machine in disconnected state. If machine is not logged off correctly then next process would not get launch.

One.more check you can do over services and check uipath service is running

Hope this helps