UI Element not found on SAP GUI

I have an automation where I need to filter data from a table. I open the filter window and then set a value for the filter.
The automation fails with an error message:

Set Text 'CTextField Operación': Could not find the UI element corresponding to this selector:
 <sap id='usr/ssub%_SUBSCREEN_FREESEL:SAPLSSEL:1105/ctxt%%DYN001-LOW' type='GuiCTextField'/>

The automation works sometimes and fails others. On the UI Explorer the element selector is always the same. Both UI Explorer and the SET TEXT activity selector return the same ID for the UI Element.
Both screens validate the element correctly in design but it fails in debug/execution.
I’ve tried to add more attributes to the selector (hence the “type” value) but it still fails.
I have the activity inside an attach window activity. I haven’t changed the window ID to wildcards because it always validates and highlights the element when I’m on Design.

The only pattern I’ve discovered is that after closing SAP GUI and executing the process for the filter ONLY it seems to work everytime. If I include the previous steps to get to the table screen it fails.

My GUI version is: 740.7
My Studio version is: 2022.10.1

Thanks for any help.


Run the bot in debug mode and keep one ui explorer open before run…and when bot fails at this step try validating it may be during runtime there are some changes int he values…you can identify them and then change the selector accordingly

Hope this helps


Thanks for the Reply @Anil_G

I tried that already and both codes for the selector seem identical to me:

<sap id='usr/ssub%_SUBSCREEN_FREESEL:SAPLSSEL:1105/ctxt%%DYN001-LOW' type='GuiCTextField' />


<sap id='usr/ssub%_SUBSCREEN_FREESEL:SAPLSSEL:1105/ctxt%%DYN001-LOW' type='GuiCTextField'/>

Some extra information on the behaviour:
The part that fails executes correctly when executed as the only step in the automation. When it’s inside the overall flow (step 5) the execution fails and keeps failing after that even when executed individually again.


Did you try when paused or you stopped and tried it?

also can you try using find element and then try the click or include click in retry activity


I tried with a clic activity before set text and the clic activity failed.
Both ids that I provided where while paused on debug after the exception for element not found was thrown.

First ID was from GUI Explorer. Second was from the text on the exception.