Type into is not working with Underscore (_) produces (-)

studio

#1

Guys i am passing some commands with Underscore (_) in type into . which is printed in cmd.exe .

The result looks like (-) instead (_)
For example: test_123 , result : test-123
Any solutions to fix this issues?


#2

Hi,
Make sure SendWindowMessage property of TypeInto unchecked.


#3

Hi Again,

thanks for reply.

i would like to say what i need.

i want to invoke a command prompt and want to perform some action using command line.

  1. Started the process(cmd.exe)
  2. using type into i was trying to print in cmnd line and performing some execution. during this i have some command containing (_) …
  3. if i uncheck the sendWindowmessages it wont print in command prompt.(Am i right)

#4

It should type .
Did you try ?:thinking:


#5

Underscores are getting populated correctly in command prompt. I tried with basic default method (SendWindow and Simulate being unchecked)


#6

Hi,

i tried it . in my office machine it is not working. in my personal laptop i can able to see _ with unchecking sendWindowmessages and simulate type.

i am using studio 2017.1.6498 Community edition in both machines.


#7

@Pradeepkumar you have to use 3 send keys to achieve this.

I tried these with out Shift key and it is working perfectly fine on a notepad. So, i changed new screenshot.
hope my inputs are useful.


#8

wow quite strange isn’t it :grinning:
what to do now? :thinking:
This might sound silly but try these:
try running workflow designed in personal laptop in office laptop.(vice versa)
same issue then something wrong with CMD itself :stuck_out_tongue:
try running CMD as Admin and give a try (don’t think so that’s the problem here)