Total Items: 14 Completed Items: 14 Correct Items: 0

@ovi,

{
“message”: “Assign Transaction item: Index was outside the bounds of the array.”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “17:14:53”,
“processVersion”: “1.0.0.0”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “GetTransactionData”,
“logF_BusinessProcessName”: “Framework”
}
{
“message”: “Error getting transaction data for Transaction Number: . Index was outside the bounds of the array. at Source: Assign Transaction item”,
“level”: “Fatal”,
“logType”: “User”,
“timeStamp”: “17:14:53”,
“processVersion”: “1.0.0.0”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “Main”,
“logF_BusinessProcessName”: “Framework”
}

Not sure what this error means, can you help me resolve this error.

On which assignment you are working on?
If it is Assignment 1, then start transaction number from Zero.

Yes, i have started it from Zero (0) only

My assignment evaluation response is

Total Items: 14
Completed Items: 14
Correct items: 0

Assign Transaction item activity is throwing an error because you are trying to read the row from a data table/ array of data rows which doesn’t exist.

For example - If your data table contains 14 rows
get 14th row from data table -> dt[13]

if you are trying dt[14] -> will throw an error Index was outside the bounds of the array.

Ok, so where should i make the change?

in GetTransactionData.xaml. What change should i make

Yes. There will be an issue in assigning the transaction item in the Get Transaction Data.xaml

Try to debug (step by step) and check why the issue is happening. Check if each transaction is executing as expected.

Regards,
Karthik Byggari

Yes, all steps are getting executed properly. The status is also getting updated for all 14 items as completed. So not sure why it is erroring out. As i have also put else condition also.

Can you send what is there in the IF condition?

The IF condition is wrong.
You have to use in_TransactionNumber < in_WIList.GetLength(0)

For example: Consider you have to process total 14 items
0 < 14 -> your bot executes 0 to 13 which count to 14 items.

Although the BOT completed, and i submitted for evaluation, i still got the same result.

I have observed one more thing, not sure why the BOT is eating up some alphabets of first name and country

1 Like

@ovi

Can you help me with my assignment evaluation? I am still not getting it right and also not able to figure out what the error could be.

Regards

Rakesh

Hi

Check with SHA1 application format ( Including spaces).

Format is: ClientID-ClientName-ClientCountry

Thanks,
Madhusudhan Govindaraju