The RPC Server is Unavilable (Exception from HRESULT: 0x800706BA)

Hi all,

I am getting this error when try to write range. How may i solve it?

1 Like


Check below post

Hope this helps


I did it with 5 seconds delay but getting same error.



Sorry, I didn’t understand your flow. May I know what are you trying to do here ?

Sometimes it happens when you didnt open the Excel but given in Excel Application scope as Visible property checked.

@lakshman, Let me show you another process that getting this error:

In this process, i a try to create a loop that work for every sheets of that excel.


I guess the below thread will help you.

Fine I have faced this many times and this occurs when the excel application is used many times consequently
So use a KILL PROCESS activity with ProcessName as “EXCEL”
Keep this before delay activity in your THEN part and also in ELSE part
Make sure that a Delay and kill process is included before READ or WRITE RANGE activity where this error occurs

Cheers @mazlumkacar

1 Like


I used this solution but the error continued in the same way.
Does anyone know any other solution?

Try Invoke method Kill ( target object is the Excel process)for the current user.

I tried, same result. Error :frowning:

And i try this one, Kill 3 processses - #5 by aksh1yadav

Some feedback.

I changed the most of Excel Application Scope for activities from WORKBOOK.
So far I haven’t had any more mistakes.

1 Like

Has an answer for this bug been discovered?

Can you rephrase or show what you mean Activities for workbook, please

For those that are still reading :

Assumption #1: Kill Process = Excel.

If assumption is correct, Bot couldn’t find the Excel application scope’s excel instance (because it was killed) and hence this Write Range failed leading to this error.

1 Like

thank you for clarifying this worked me as well :slight_smile:

I received an error when exiting Balareva Excel Scope. I solved it by introducing this block in Try Catch