'The Operation has timed out' error where the user tries to install package

Hi, I have a PC where I installed the Attended Robot to run my automation. but it keeps getting this timeout error whenever it tries to install the package. also sometimes I get this ‘automation not found’ too.

I have tried everything including reinstalling, tried on different PCs and using different networks but nothing works. the assistant logged on to the account just fine and the browser extension also installed with no issue. any idea what caused these?

Hi @feedrpa,

It sounds like you might be encountering a few different issues with your Attended Robot installation. Here are a few things you could try to resolve the problems:

  1. Timeout error during package installation:
  • Check your internet connection and ensure that it is stable and fast enough to download packages.
  • Verify that the package you are trying to install is available and compatible with your version of the Attended Robot.
  • Try clearing your local NuGet cache, then restart your machine and try installing the package again.
  1. Automation not found error:
  • Double-check that the automation you are trying to run is published to Orchestrator and is accessible by your Attended Robot.
  • Ensure that the automation is assigned to the correct machine and user.
  • Check that the Orchestrator URL and credentials used by the Attended Robot are correct and up-to-date.

If none of these solutions work, you may want to reach out to the UiPath Support team for further assistance. They can help you troubleshoot the issues and provide guidance on next step


Hi @feedrpa,
Try out below,

  • Check your internet connection
  • Check the package source: Make sure that the package you are trying to install is available in the package source that you have configured in UiPath Studio. You can also try adding the package source URL directly in the package manager to see if it resolves the issue.
  • Clear the NuGet cache, go to ‘C:\Users\AppData\Local\NuGet\Cache’ and delete all the files in the cache.
  • Reinstall UiPath: If none of t

Hi, thanks for the reply. I’m sure my Assistant could connect to my Orchestrator since it shows all the automations available that I’ve published.

Also does the UiPath version matter? as I developed in UiPath studio with older version 22.12.0-beta.11471 and the attended robot is using 23.2.0-beta.11986.


Check if firewalls are blocking robot to connect…

If its your personal laptop to check you can turn off the firewall and then try running…


Hi, Firewall is off and we tried different internet sources but still no avail, which is really strange.


Is license procided in orchestrator?

Can you check if the machine template is created properly and license is allocated to the user connected


Can you give a step on how to check and do that? sorry I’m still fairly new with UiPath.

(the top machine is mine and it works just fine but not on the machine below it)


Please check this

Machines can be created in tenants and then add the machines to the respective folders

Then create robots/users and assign license to them add those also to the respective folders


I added new Machine with the exact same Machine Name, used the machine key and logged on into the orchestrator and it shows connected and licensed. but I’m still getting the Operation has timed out when installing the package. do you think this is connection issue? (but the user has tried different networks that’s should be unrestricted)


As per the connection and license it does not look like any issue.

Can you confirm your studio robot and orchestrator versions and if they are of same or compatible versions