The maximum number of jobs for this Process has already been reached (#1693)


I often get the following error message from Orchestrator:

Folder Produktion: #trigger XXX__Trigger_Name__XXX for #process YYY__Process_Name__YYY could not create jobs. The maximum number of jobs for this Process has already been reached (#1693)

My settings for the trigger are:

Minimum number of items to trigger the first job. 10 item(s)
Maximum number of pending and running jobs allowed simultaneously. 1 job(s)
Another job is triggered for each 1 new item(s)

So my understanding is, that there are created only max. number of jobs and there should not be an error message because it could not create more than max. number of jobs.

Is this a bug or can i prevent this error somehow?

If you intend to inform the admin about more needed jobs, maybe a warning would be better than an error. But in this case the admin should be able the enter a value for the number of items to trigger another job even if the max. number of jobs is set to 1.


1 Like

I agree, even if this operating correctly it is not intuitive at all!
Trying this as a solution

Hi ewanc1,

I had read this post with the workaround before, but I thought it would be better not to need a workaround. :wink:

So I thought I file this problem as a bug and see what the official reaction is. Maybe it really is just a misconfiguration. Or a real bug, that will be fixed.

Or the behaviour is intended. Then I will have to use the workaround…


Hi OKlink,
I am having the same problem and would also prefer not to use a workaround.
Could you please update me if you get more information about this?

Best Regards

I think this is expected behaviour and the solution from the linked post is the way to set it up in a 1 robot scenario.

Further more, it is possible to turn off these notifications under your profile:

1 Like

An error should never be expected behavior when there are settings that tell it “don’t try to create more than one job” and it tries anyway. It trying to create more than one job, when the max is set to 1, is obviously a bug in Orchestrator.

1 Like

I agree. It should not happen.

It is there for historical reasons (classic robots could have only one pending job… so we gave a warning) but we should change it for queue triggers.


110% agree on this, i get hundreds of mail each day because of this in a fully modern setup with two unattended where we limit the queue to a single process to leave the other license open for other processes to run.

I get that I can turn of the warning, but if i do, could there be legit trigger warning that I’m missing if we start to use more of these. That is my concern.

This has been giving us issues as well. Placed a ticket and they mentioned it was by design. This doesnt sound correct since it’s trying to do something we didnt configure it to do.

Any word on fixing this? Another good example of why it’s a huge problem is we just turned on Alerts in Orchestrator. So then we get tons of long emails listing all the times we go the “trigger cannot create job” error.

Hey, are there any updates on this?