The indicated element does not belong to the target application / browser

Hey hey,
I learnt about Reboot Your Skills very late so I’m trying to go through it fast but I’m super stuck with Week 1.
All the tasks with “Type Into” actions cause the error “The indicated element does not belong to the target application / browser”.
I reviewed solutions in this forums but to no avail. I tried both Chrome and Firefox with the same result.

It will be nice if someone can point me in the right direction. I don’t want to give up on Reboot Your Skills / or throw the computer out of the window :slight_smile:

Update: The problem seems to be the resource Use Application/Browser. I tried recreating simple tasks with Chrome, Firefox the DoubleUI.exe program and I always get the same error message. Can someone help please?

Hello.

I noticed in your screenshot that your URL is blank. Can you try indicating the window again? You need to first load the application/website you want to automate, then select it when you indicate the element:

image

Also, click on Highlight Target, to see if it’s working before moving to the inner activities.

Regards.

Hi Clayton,
Thanks for your advice. I confirm that I did load the application/website as you said and then indicated the element.

Meanwhile, I attempted installing StudioX on my second, personal computer and create the same tasks and I no longer get the error messages.
My conclusion is that the StudioX installation on my work computer was not successful and that’s why the Resource didn’t work properly. I’m now in touch with our IT to see if they reinstall StudioX will help :crossed_fingers: :crossed_fingers: :crossed_fingers:

1 Like

Hey @ClaytonM,

Unfortunately, the re-installation of StudioX didn’t help. I still get the same error “The indicated element does not belong to the target application/browser”.

I can confirm that:

  1. Tasks using all other resources (Excel, Outlook, Word) work for me.
  2. If I recreate the same tasks with the Use Application/Browser resource on my second, personal computer, I get no error.
  3. I downloaded the solutions from the 1st week of Reboot Your Skills. If I run “Solution - Robot Path Steps - StudioX Project” and “Solution - Create a Strong Password - StudioX Project”, there is no error. However, if I start a new project using the very same steps, I get an error.
  4. I did notice as you said that if I take a screenshot from StudioX, the URL is showing as blank although it is correctly indicated and Highlighting the Target also works as expected.
  5. I also noticed that the URL shows the path starting with MyDocuments which I don’t understand because this is not where StudioX or my resource files are saved.


Do you have an idea what may be the issue here?

Can you upload the .xaml file? Maybe I can look at it.

Sure Main.xaml (9.4 KB)

Ok something weird happened when you selected the application window, which added “My Documents” to the selector. This causes the inner activity to not work.

You can fix manually by selecting the “Use Browser…” activity, then on the right side, go to Properties, and edit the Selector:
image

You want to remove everything except the selector part.
So it looks like this:
image

Hope that helps.

Thanks for the tip…but I am not able to edit the selector. The “MyDocuments” part stays in.

That doesn’t happen for me, yikes! Try erasing the selector completely and see if it empties it.
image

If that works, then place the selector back in:
"<html app='chrome.exe' title='Password Generator'/>"

Also, if it won’t let you update that field, make sure the .xaml is not ‘Read-Only’, though that is unlikely.

If none of that helps, then check what version you have for the UiAutomationNext activity package by going to Manage Packages in the ribbon. And, you can check the Studio version by going to Help.

Hmm…I tried erasing the selector completely but it doesn’t help. MyDocuments stubbornly stays in.

The xaml file is not read-only.

The UiAutomationNext version is 20.4.1 and the Studio version is 2020.4.1
Is that what it should be?

I think your versions are good.
Have you tried to starting from scratch again to see if you can get the indicate element and selector correct?. You can also copy and paste the working activities over.

Hi… I am having what looks to be the same issue. Any advice? Thanks in advance!

Hi Clayton, yes, I’ve tried starting over but I get the same error.
Our IT department unistalled/reinstalled the programme again and I started from scratch but the pesky MyDocuments stays in.

@Andrew1, unfortunately I don’t have any advice. I see that you’re from RELX as well. Maybe it’s something to do with it. Although I know that our colleagues use StudioX without issues :expressionless:

@kj.fenton @magizoologist Do you know what’s going on here?

Yeah so this is weird to me as it does seem to be some sort of provision that is linking browsers to your “My Documents” folder path as the selector which obviously isn’t right. So I have a couple questions for you OP, and @Andrew1:

  1. Did you try this in IE by chance as see if you get the same error? Doesn’t require any extensions so maybe it’ll help.
  2. Is, for whatever reason, there a chance that a shortcut or something exists in your “My Documents” folder for Chrome and Firefox? That could be causing this issue if it’s trying to find that path inside the selector versus using the direct link to the browser.

Regardless, let me know. I’d like to escalate this internally and see if there some sort of provision that is causing this to direct you to that folder path for a browser - which we all agree shouldn’t be happening. It could also be a bug and I’d welcome you to try and use an “Attach Browser” in the Studio profile and see if the same issue arises.

Thanks, all, for getting back to me.

@kj.fenton:
Having the same issue in IE and don’t see any browser shortcuts in My Documents. Let me know if you have any other suggestions or need screenshots/more information. If we can get it worked out by early- to mid-next week, I’ll still try to complete before May 31. Sorry I’m so late with this!

@kat Agreed, haven’t heard about this being an issue for our other colleagues. Did you end up carrying on with exercises or is there not much use to that?

@kj.fenton

  1. I get the same error using Explorer, Chrome, or Mozilla. The same error appears for applications too, e.g. Notepad or the DoubleUI application downloaded from the course
  2. I have no shortcuts in the My Documents folder.

The “Attach Browser” activity in Studio works for me. I have no errors there.

@Andrew1
I completed the tasks in Week 1 which didn’t require a browser/application. Sadly, since I’m still getting the error I won’t be able to finish the course before May 31.

@kat and @Andrew1, this is just odd to me. I’m reporting this to the StudioX team and hopefully we provide some insight as to the issue here. My advice would be to try and complete the exercises on your personal machines as there seems to be no issue with that install. Deeply sorry about the experience y’all are having though.