The Browser Failed to Launch

Hi there,

I am using open browser and when I try to login to the citrix (app), I receive the “browser Failed to launch” error message. I do not see the same issue when I use Use Browser/ Application (modern). However, I’d like to proceed with the classic one for this project. Can anyone help with this?
@Anil_G and @Yoichi for your visibility

Thank you!


did you try with classic activities?

those classics will be more reliable for your citrix automation


@fernando_zuluaga Yes, it is classic activity, but it keeps failing with the error “Browser Failed to launch.”

Please let me know if there is a missing step. Thanks!


For now can you try to open the browser with the Start Process activity?

and then attaching the browser?


Hi @Sisay_Dinku,

I know it can be a silly question, but do you have all extensions installed?

If you do, have you tried to reinstall them?

Can you also attach a screenshot of your properties?

@Schirru yes the extensions have been installed

@fernando_zuluaga I did that but still having issues typing the credentials into the logon fields


So i think that the citrix receiver isnt working properly, probably you would need to change your type of automation for Computer Vision and Imagen Automation


I was trying to use native citrix under recording but still seeing the same error

I’ll see the other options you just suggested.

@fernando_zuluaga Yes, the image solution, works. I am able to login to Citrix. I wonder if that is a standard way of doing it. Thanks

1 Like


Once the login page of the citrix is open, I am able to login using image automation. However, I’d need the to use the URL of the citrix using chrome browser. When I use open browser. It looks like not working. Any advice? Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.