Test Manager installed completed, but the Test manager is still not loading in the browser

I have installed Test manager application 20.10.4, I have completed all steps as mentioned in the installation doc but when I load the application in the browser, It does not open and gives below error -
This page can’t be displayed. please suggest

Did you kick start your local tomcat server on port:8443 ?
use command prompt and check Ping command for port:8443.
Example: ping 182.168.1.1:8082
If you get response then your port is working. if not getting the response then you need to enable your tomcat server (if you deploy on tomcat server).

Hi!
This looks like there is a problem with the authentication service. Are you able to log into the associated Orchestrator instance?

Gernot Brandl

Hi, thanks for responding!

yes, I am able to log into the Orchestrator instance using the same admin credentials, I had put in during Test Manager Installation.

I am still not sure what the issue here is.

There is something wrong with the URL. It seems that testmanager.local does not exist. Also the return URL does not match. What URL do you use for Orchestrator? Is it on the same machine and configured properly?

Hi @chaudhary.vidhi07 ,

I am trying to install Test Manager but when I accept the license agreement and click on Next, I am getting this error:

It is showing that the following windows features need to be enabled in windows settings but which windows features do I need to enable. Please help, if you know about this error.

Thanks in advance.

Hey dimple,

The same thing happened to me. Please go through the below link - Software Requirements and Prerequisites
and check if all prerequisites are met, especially the IIS settings.

Thanks!
Vidhi

Did you ever find a solution to the initial problem with the Test Manager install?
I’m seeing the same thing. It looks like the return URI on mine is pointing back to the orchestrator address rather than the testmanager address on 8443.

thank you for any assistance!

David

yes, that’s resolved now. In my case the test manager URL was not correctly given at the time of installation, it should full domain name of the machine and port number.

Hi, @chaudhary.vidhi07,

Could you send your test manager URL so I could see what it is? I’m getting the same issue currently in which using the testmanager.local:8443 URL isn’t working for me.

Thanks!

Hi James, what is the error message? I tried to install it in a local VM and it worked. Attached my configuration.

1 Like

I get “HTTP Error 502.5 - ANCM Out-Of-Process Startup Failure.” (It was an InProcess Startup Failure at first, but someone who does IT at my work went through with me and we modified a .config file)

Do you have some information what “event log” says?

I got this from Windows Event Viewer:

Application ‘/LM/W3SVC/3/ROOT’ with physical root ‘C:\Program Files (x86)\UiPath\TestManager’ failed to start process with commandline ‘dotnet .\UiPath.TestManagementHub.WebAPI.dll’ with multiple retries. Failed to bind to port ‘40590’. First 30KB characters of captured stdout and stderr logs from multiple retries:
Failed to start UiPath Test Manager.
Microsoft.Data.SqlClient.SqlException (0x80131904): Cannot open database “UiPathTestManager3” requested by the login. The login failed.
Login failed for user ‘xxxxxxxx\james’.

@James_Gebler:
It seems, that you cannot connect to your database.
Can you access the database with the used credentials via SQL Server Management Studio?

Hi, I have the same problem.

After the install, I accessed the URL, and at the tab of the browser, the logo of test manager appeared for a moment at first, and then immediately transitioned to the error page.
I suspect it’s an authentication issue too, but I’m a little confused as to how to fix this. If you are able to solve this problem, could you please let me know how you solved it?

Thank you !

hi @111962

can you post what event log says please?

thank you for your replay.
I changed the test manager URL and reinstalled test manager then this problem solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.