Terminal automation (AS400 environment): "Function key not allowed"

terminal
error

#1

Hello,

I’m trying to automate a workflow in an AS400 environment. To confirm an entry I have to use the F12 function key. However, when using the recording function in the UiPath Terminal Wizard, I get the error “Function key not allowed” within the terminal. I do not get this message when tyring in AS400 itself (without the UiPath Wizard).

Does anyone recognize this problem and can help me with this?

Thank you in advance!
Kr,
Caroline


#2

Hi,

I managed to fix the problem. Apparantly the function keys were not correctly interpreted because the connection type did not match the type of the terminal. I used this file for translations:

https://www.ibm.com/support/knowledgecenter/en/ssw_i5_54/rzaiw/rzaiwkeybrdmap3270.htM


#3

Hi, couldn’t access the url
The requested resource is not found: /support/knowledgecenter/en/ssw_i5_54/rzaiw/rzaiwkeybrdmap3270.htM


#4

Hi Caroline,
I am also facing the same issue, function key is not allowed in uipath terminal. Can you post how did you solved this issue. Also, the url you have shared is showing “The requested resource is not found: /support/knowledgecenter/en/ssw_i5_54/rzaiw/rzaiwkeybrdmap3270.htM”


#5

The correct URL is : https://www.ibm.com/support/knowledgecenter/en/ssw_i5_54/rzaiw/rzaiwkeybrdmap3270.html

(l was missing at the end)

On this page you can find a mapping of the function keys. Instead of F12, I had to press PA1, then F12.

I hope this helps!


#6

thank you so much. Works like a charm


#7

Hi Caroline,
To press enter, i tried giving control key as transmit. It is not working. what is the key mapping for enter key


#8

Hi DeviE,

The mapping for ENTER key is not mentioned in the link so I’m afraid I won’t be able to help you with that.

Maybe first question you should ask is whether you are using the right terminal connection.
We are working with a AS400 terminal.

In the beginning we used the UiPath internal terminal connection.
Now we are using the IBM EHLLAPI terminal connection. Now all our mapping issues are resolved.

By the way: I am also a starter so no expert.