Take screenshot results in "Save Image: Object reference not set to an instance of an object"

I’m troubleshooting a problem, and want to use a screenshot to check if I have resolution issues. The attached workflow works when run from Studio, but when I run it from Orchestrator it gives the “Save Image: Object reference not set to an instance of an object”-error. Any ideas?

Main.xaml (4.9 KB)

Is the user being used to run this from Orchestrator have a logon session? If so, you might try signing the user off first, then try again. I have gotten this error a few times, but seems intermittent and usually has to do with the user’s session is corrupt.

I am curious too if there is a proven reason for receiving this.

Let me know if signing off the user helped or not.
EDIT: to sign off user in RDP connection, press Ctrl+Alt+End, or from Task Manager as an Admin account


Tried signing out, and then signing in again (on the VM) like you said, and that seems to have fixed it, because it’s working now. Thanks a bunch!


Bleh. I was wrong. It worked once and now I’m back to having the same issue.

Introduce some delay between Take Screenshot Activity and Save Image around 2 or 3 Seconds.

I added a delay like this:


I also made some adjustments so if the Save Screenshot errors, it will Log it correctly rather than just say it saved it - Note: I have Save screenshot’s ContinueOnError poperty set to True, so it won’t stop a process from running.

Also, make sure this is in a shared workflow snippet that you can invoke :stuck_out_tongue:

Hopefully, this helps us both out!


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.