Take screenshot and Send mail

Hi everyone, I am working on an automation in which I want to take a screenshot and want to send that screenshot with outlook mail. I have completed this activity but now It is creating issues when I run again this. Can anyone let me know How it is possible every time activity save and send latest screenshot automatically?
Regards and best Thanks

Hello @mtalha.shafiq

What issues, in particular, are you experiencing? Can you share a screenshot of your automation on StudioX, or the error message/prompt you get when you run it?

You are using the REF? It is taking screenshot already. You just need to send it. Also you might want to use the Exchange activity instead of Outlook, works more reliable.

@afe.araromi @moenk
HI, I have same issue for one thing as well once my script click on Maintain button but next time it doesn’t. you can see in attached files my activity and error as well. If it will run successfully I can show you screenshot error.


Any reason for using Click OCR Text instead of the regular Click activity?

@afe.araromi I tried simple but that was not working fine.

If you are working with a webpage then I think a regular Click activity will do it.
The challenge you may have had with using the regular Click is likely a selector issue; if this is the case then I suggest you fine-tune the selector. Can you do that?

not exactly but i know i have to go into edit selector. I have shared in above pic I have to choose Maintain button.

You could use the Web Recorder wizard in a separate workflow file to record your “clicking” on the button so you can see what the wizard comes up with.

I am currently out of the house at the moment. Maybe we could jump on a Zoom call at 3:30 PM (WAT) so we could look at it together, what do you say @mtalha.shafiq

Hi All, finally, was the issue with selector unable to locate it correctly? or any other learning.

@JayakumarSanthanam The button was changing during loading process that’s why click activity was confused to detect it.

Thanks for writing, was it changing the location? or the change of size/colour. how did you fix it?

@JayakumarSanthanam It was changing color. so we tried Retry Activity which was solution of our issue.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.