System.Exception: The type initializer for 'UiPath.OCR.Contracts.Scrape.ScrapeEngineProvider' threw an exception

I am getting this error when I click on manage templates in my form extractor
Error: System.Exception: The type initializer for ‘UiPath.OCR.Contracts.Scrape.ScrapeEngineProvider’ threw an exception.

—> System.Exception: Could not load type ‘UiPath.Platform.ObjectLibrary.FileSystem.Index.IDesignObjectLibrarySettings’ from assembly ‘UiPath.Platform, Version=, Culture=neutral, PublicKeyToken=null’.


Welcome to the community

  1. As a first step try changing the version of the package and then try
  2. Alternately go to %userprofile%\.nuget and rename the packages folder and reopen the project so that if any package is missing it would redownload the same

Hope this ehlps


I’m also facing same error when i click on manage templates. I’m not able to manage template
@Anil_G @loginerror @supermanPunch
%userprofile%.nuget @Anil_G where can i find this folder?
I think its an UiPath.IntelligentOCR.Activities package issue

@nabeamartin did you found any solution?

@ppr @Lahiru.Fernando @Yoichi Any idea about this error?




I have tried deleting the packages for OCR and they get redownloaded when i restart the project. But I am getting the same error


Looks like an error on the platform package only…rather rename the packages folder completely and then let all the packages redownlod


Go to your OCR activity that’s inside another activity. Find where it has the “Image” input for the OCR activity. Delete the word Image, press CTRL+K and type Image again then press enter. It seems the datatypes are messed up between versions.

When I created a new fresh workflow with new project it works

1 Like