Studio frequently goes unresponsive

Hey guys,
I have been using Studio for a little over a week now, and have noticed that I constantly have to close studio and restart it, in order to either run a script or make a selector work.

This is the first version of UiPath on this machine. Here are the specs everyone asks for:

Studio 2022.4.1 - 5/2/2022
Community License
Per-user Installation
License Provider: Orchestrator
Activation ID:
Update Channel: Stable
Microsoft Windows 10 Enterprise 64-bit

I have no idea if it is an issue with the studio, the executer, orchestrator, or what. I can tell you all I have done up to this point is follow tutorials in studio and used the run or run file button to make things go.

When the run button(s) stop working, there is no error message I can find. Sometimes, when I am trying to run a file, I get an error talking about a pipe being closed.

It is seemingly intermittent, and I can’t make it happen on purpose, but I will end up closing the app and restarting it for about every other activity I add to my script.

Is anyone else seeing this going on in their studio?

David Puthuff
Dell Technologies

Hi @David_Puthuff ,

Could you please try restarting the robot service,

Services-> Find below two services and restart them.


Hello @David_Puthuff ,

Can you check your system configuration also. Plz refer the below document .

Interestingly, I do not see anything in my services having to do with UiPath.

Are you working off of local files or from a network share?

It seems Studio is very disk read/write intensive, like every little thing you do causes it to write something to disk - including that it seems to revalidate everything every time you change something. Over a network - especially VPN - this can make Studio very sluggish.

I am using local files as I learn.

I have the same issue, I’ve been working with UiPath now for over 3 years and every now and then I’ve experienced this but more so lately.

It has got to the point where I will click on an activity or try to scroll or anything really and it takes about 2 to 3 seconds to 30 seconds to respond. I am now experiencing converting a sequence to a workflow take 11 minutes. At first I thought UiPath Studio had crashed but forced myself to wait. This has happened on more than one occasion.

I work with files locally, I am connected to the office via a VPN. I have also tried working on a project on our Virtual Servers and thus working on the office network directly essentially and not enduring the latency of the VPN to access files with the project files also on the office network.

Some days it’s fine some days not. Other people in the organisation are also experiencing this.

Our machines are rebooted everyday whether we like it or not. This morning I logged in at 5am to rule out network related stuff or contention with Orchestrator perhaps (minimal people using it), I’ve tried killing the UiPath processes and relaunching the assistant and studio to no avail.

One thing that is new in our environment is that I get the following error when launching UiPath Assistant
‘Invalid token specified: Cannot read property ‘replace’ of undefined’
But again - regardless of this error - sometimes my working experience is good sometimes bad
My Studio and Assistant are both the same version 2021.10.4

I’m using version 2021.10.4
Enterprise license
MS Windows 10 Enterprise 64 bit
I have 475 GB FREE on the machine

As I say sometimes it’s fast, sometimes not. I have experienced the inconsistency with the SAME project so have now ruled out a corrupt project I would say.

Hi. I was getting this when I had a giant robot file because the .xaml robot file had way too many lines. What I did to fix it was divide out the huge robot file into four smaller robot files. So, question, if you use Studio just for maybe a message box, does it also freeze?

This indicates it’s not Studio, it’s your network or system. Antivirus? You said you work from local folders, but which ones exactly? Maybe you think they’re local but they’re not - like mirrored folders, roaming profile etc.

Try working directly from something like C:\Temp

Thanks Paul, I did see a post somewhere else where someone was mentioning Antivirus.
Will give your c:\Temp suggestion a go as the “local” files I am working on are synced with Onedrive.