Studio flow works but Assistant/orchestrator does not

Hi Team,

My Studio Workflow runs smoothly, but when the Assistant/Orchestrator job runs,
it throws an error. “Workbook does not exist”

Screenshot: Assistant



Screenshot: Studio


Here is my flow

Here is the Retry Scope


I download a Tableau Crosstab and tried both Today.tostring(“yyyy-MM-dd”) and Today.AddDays(0).tostring(“yyyy-MM-dd”), to see if that might be the issue, but it didn’t work.

I added delays between downloading and reading, but that too didn’t work.


All my folders on Orchestrator are linked to the unattended bot,
and one can see if I trigger the bot manually via Assistant directly after publishing, it works,
but then it does not work when the Time trigger activates the process.
Then Manually triggering the bot on Assistant fails again.

I ran out of Ideas, any help would be great, thank you.


When you are running workflow from studio, It will work because you keep the worksheet inside the project folder

like “Input\DMT Report” etc

But when you publish to the Orchestrator that will expect the fullpath of the file, let’s say if the file is in a location of D:

Then you have to specifiy D:\Input\DMT Report

Hope this may help you


1 Like

Hi @Srini84 ,

Thank you for the reply,

Thanks, I didnt realize this would be an issue, and makes sense as some of my other processes
do not have locations to the package folder.

Ill do the changes quick and let you know

Thanks again

Thank you @Srini84 ,

I ran the process via Assistant 5 times with no issues.

I will check the coming days if this changes, but seems to work perfectly.

Thanks again for your help


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.