Starting job failed with "Forbidden" using start job activity

Hello,
I was trying to start a job using start job activity, and failed with “forbidden”, I have checked some other topics and seem all requirements are fulfilled, please help.

My activity looks like:

My role permission looks like:

Error looks like:
{
“message”: “Start job : Operation returned an invalid status code ‘Forbidden’”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “15:48:02”,
“processVersion”: “1.0.6809.35830”,
“fileName”: “Test”,
“jobId”: “291d07f8-8712-4eee-bd66-d8c4c9bf7ee2”,
“robotName”: “Developer 012”
}

BR//Pengfei

Hi @Pengfei, can you add the View permission for Settings?

Hope this helps.:slight_smile:

Hi,

I’m having the same issue. Keep getting the forbidden error.
I can see in other topics, that I’m not the only one. there has to be other things than user permissions giving this error.
My user have permission to do everything in orchestrator, so it is clearly not a permissions issue in orchestrator.

Hi @quihan , the View permission was added for Settings and retried today, but still get the same error.

BR//Pengfei

Hi @Pengfei, are you using your own orchestrator or the free orchestrator?

Cheers,

Hi @quihan, I was using our own orchestrator, We were just setting up our RPA team. While we have quite a lot of this requests from operation team, I am testing it and hope it would be used for production soon.

Regards

Hi @Pengfei, can it be a firewall issue?

Cheers.

Hi,

@Pengfei

Roles changes need to be applied to the role “Robot” (as it is effectively the executor which is starting the job) and not to the developer role.

Could you give a try?

Cheers

7 Likes

@Florent_Salendres is right, the Robot role needs to have those permissions.
Check this: https://activities.uipath.com/docs/start-job

Thanks @Florent_Salendres and all, the problem is solved now.
Necessary permissions should be applied to “Robot” role, Not “Developer role” as what I did before.

BR//Pengfei

3 Likes