Start Job: Operation returned an invalid status code 'Forbidden'

{
“message”: “Start Job: Operation returned an invalid status code ‘Forbidden’”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “11:52:15”,
“processVersion”: “1.0.3”,
“jobId”: “b047616c-2068-46d3-96af-947d19bc6bf4”,
“robotName”: “R1”,
“machineId”: 75541,
“fileName”: “Main”
}

@sandipauti

Is that machine is connected with Orchestrator or not ?

@lakshman - Yes machine is connected to Orchestrator , I’m currently using community edition, after lot’s of research i got to know that like robot role need to give all permission but currently i see only one user in my orchestrator.

@sandipauti

I guess you have Admin account for Orchestrator. If yes then you can give roles to other user accounts.

1 Like

@lakshman - is this solve my problem ?

1 Like

Check if you gave the Robots the roles to launch Job :wink:

Users->Roles->Robot->Jobs (enable create)

Hope it helps

3 Likes

@jfinet - i’m using community edition where i am able to see single user and not able to see roles and all.

Hello @sandipauti . I am trying to elobarate @jfinet’s steps. If you are in the cloud rpa platform, please click on services and switch to the corresponding tenant. In the respective tenant, click on your username icon --> Users. Then click the tab adjacent to called “Roles”. In roles, click on “Robot” and click the hamburger elipses icon and then click on edit. Enable “create” role for Jobs and “Robots”.

3 Likes

@sandipauti

You are certainly missing the “Roles” Tab in the top left corner when you are in the Users page from the Orchestrator

@Deebiga_Kandasamy - Done with all the steps still i am getting same issue.

@lakshman, @Deebiga_Kandasamy , @jfinet - This issue is resolved after given view permission to environment and process for robot page

12 Likes

Great @sandipauti

I am also having this issue and am unable to find the ‘roles’ link…

2 Likes

@pduffy Here it is!

2 Likes