Start process through PowerShell

Hello everyone,

I’m trying to run the process through Powershell. I have everything I need to run (authorization, etc.). When I run the

Start-UiPathJob -Process MYPROCESS -Robots MYVDI

command, an error pops up on me:

Please give advice on how to write it correctly
Thanks a lot! :slight_smile:

There is a good discussion about this on the forum at How use PowerShell to start process - #8 by Remus_Rusanu

I have been looking at that but my problem is not solved there :frowning:

yes it is solved there… you cant pass the process name, you need an actual process object that can be get as:
$process = Get-UiPathProcess -Name MYPROCESS

1 Like

As I said, I tried everything on this site and unfortunately it throws me the same mistake in all cases.

Attaching screenshot:

I had to add the environment and then it started working :slight_smile:

yes. that was returning null because it didnt have the environment, im happy you made it work :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.