SOLVED/WORK AROUND: SOAP Activity doesn't display full XML responses

studio
p_solved
api

#1

Hi all!

Recently I have started working on the SOAP activity. I was able to setup the full process from start - receiving a token to finish - closing the session. However, in the response of the SOAP request I don’t see any XML tags. The only thing I see is the response value. In the image below you can see that the first response is a token (no xml).

Then I send a query and I am awaiting a xml response that should look the same as below xml. But the only thing I see is SelectionResult. Finally I close the session and still I don’t receive a XML response, which looks like the final block of code. So, I have created my own text response.

    <?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
        <FindByNameResponse xmlns="omitted">
            <FindByNameResult>
                <Token>0</Token>
                <SelectionCount>12</SelectionCount>
            </FindByNameResult>
        </FindByNameResponse>
    </soap:Body>
</soap:Envelope>


<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
        <CloseResponse xmlns="omitted" />
    </soap:Body>
</soap:Envelope>

So, the question is why don’t I see the XML responses? I tried to solve the problem myself by watching the video tutorial but I don’t see this issue coming up in the video

Thank you in advance guys!

Regards


#2

Hi all, it has been 5 days since I posted the issue. I haven’t found a solution yet. So, I would appreciate your response and sincere help.

Regards,
Vladislav


#3

Hi,

Did you covered all our articles about SOAP? Here is an article about how to use SOAP activity: https://www.uipath.com/kb-articles/consuming-soap-web-service-get-weather
SOAP activity result is a string that must be deserialized to obtain XML file.

Thanks,
Cosmin


#4

Hi Cosmin, thanks for the response. I have read the article but I haven’t found an answer there. To deserialize XML the response should contain XML tags. However, the responses I have are just plain text with no tags at all. I only receive a value which theoretically should be enclosed in a tag. So, at this moment the workflow works if the response has 1 parameter with only 1 value, but if there are multiples then it doesn’t work. It shows me an aggregated value “SelectionResults”.

Hope the description of the issue is more clear now.

Thanks!


#5

Hi,
Could you share your WF (if possible)? If not, i am not sure we could help, as the problem could reside in the service that you are using.
If you are making a request using other third party tool you are able to get an XML from the service?

Thanks,
Cosmin


#6

Hi, unfortunately I can’t show you the WF because I am connecting to a API with sensitive data. But I can share it with you without the login details.

SOAP_VanDijk.xaml (17.4 KB)

I have tried to connect to the API using Postman app. That application displays the XML data correctly. So, I suppose that it is a problem within UiPath.


#7

Is the token that you received in first request used in the second request for authentication/authorization?
Regarding that we don’t have access to the service, it is on your own to debug this.
Thanks


#8

hi Cosmin,
What I can do is I can send you the token which has a limited life span. Using that you can authenticate yourself and test the service.
Thanks


#9

hello vsadykov

can you send us that token to test? you have also a zendesk issue raised?


#10

Hi all! Thank you for your help. This issue has been solved. I’ve been advised to use the HTTP Request instead of the SOAP request. It works a bit different but the result is satisfactory. Thanks again!