Silverlight based web application 'Click down' not working

I am trying to automate a drag drop operation on a Silverlight based web application.
I have installed the Silverlight developer extension provided in studio but still I am unable to get the desired result when I use click activity for Click down operation.

To Perform drag and drop I am using Click down to grab an element on screen then hover activity to move it and click up to drop it to the desired location. The studio performs these operations but fails to grab the control to drag it, instead it drags only the mouse pointer to the drop location.

Check the solution here instead of using click down then hover.

Thanks for the response @Emman_Pelayo. But I tried that as well. the problem is that click down is not grabbing the element on the screen and just performing normal click.

Honestly it’s hard to imagine what is happening but you may trial and error using different combinations. (e.g. Use send window messages/Native clicking instead of simulate, hovering first before clicking down, clicking left before clicking down)

I have tried the send window it is not working and for Simulate it throws an error “Invalid mode parameter for click method”.

I will rephrase the problem: the click down activity simply clicks on the element and fails to drag it to the drop location.

Hi Harshita,

Do You have a resolution for this issue ?Please share as i am facing the same issue now.

Thanks,
Kiran

I’ve noticed that no one has arrived to a result so far, but I just wanted to add that I’ve tried to change this in several ways (using Click_UP, Click_Down, not using them…) without success.

Also, the Silverlight plugin hasn’t helped me either.

If you are sure you can select the right source element to start the drag operation and the right spot for the hover to end, then it should work ok… https://www.uipath.com/kb-articles/how-to-automate-drag-and-drop

The problem is that the Click Up never happens, even though UiPath Studio says it’s successful.

Below you can see, perfectly done as the tutorial says, but useless for Silverlight.

I’ve also tried to add some delays, because Silverlight interface is quite slow sometimes, but hasn’t helped also.

do you see you mouse cursor move to the right spot? you dont need any selector in the mouse up…

Yes, I can see the cursor there. And it effectively clicks, but doesn’t hold.