Sharepoint Upload File not working

Hi Team,

I am trying to upload a file on sharepoint using Sharepoint application scope. I have used upload file for uploading file. but it is giving me error -

Upload file: The remote server returned an error: (409) Conflict.


You already have the file which is older than the existing file in the server @Paresh

Try uploading new file or the latest version of file


I have tried with New file, It is still giving the same error.

Can you try changing the Item URL in the upload items as a simple subsite inside the sharepoint instead of entire path @Paresh

Can you please provide the example? That would be helpful.

Just change the ITEM URL @Paresh, I hope you are providing the some wrong path there. Can you try changing it

where you able to resolve this issue?

Just check the Item URL, take a look to the screen.


No it is not yet resolved. Have tried your solutions.

How are you writing the Item url?
Could you show us?

SharePoint does not create attachments folder when item has been added. You can check it with SP Designer. So, you would need to create this folder by yourself. or make a flow to crate a folder first.

Hi Why my activity looking like this.

It showing me a VB expression in both. In local and Remote filed. instead of showing me URL and the loacal file path. Am I using the different activity or same. Please help.

what is that activity you used, for Application Scope?


Hi @Paresh,
I am faing the same issue, were you able to solve it?


I had this problem too when I was trying overwrite the file.
I found it is thrown when you or someone else have the file open.

killing the process does Not works you have to close tab and delay around 3 seconds.

I used a check out activity in a try catch, the exception (ServerExeption) message is more complete

This is the messsage when you use Check out file