UiPath and Sharepoint

I’m trying to upload a sheet file to sharepoint. Clicking and recording aren’t working, either isn’t tabbing. I tried binding the click to full xpath, but I don’t really know how to use it. I downloaded a Microsoft365activities package, but I’m missing something. Do I really need to download Azure pack as well to get this simple does done…? Help anyone? Thanky you

Hi and welcome to the community!
You should download and try this package:

The same problem is with other web site. I can record web type into user name and password, but as I try to click ok, nothing happens. Inputting hot key enter won’t work.

Thank you, I’m one step further doing this, but unfortunately I keep getting error Upload file: The remote server returned an error: (409) Conflict.
I read other topic about the same subject, but it didn’t help me what info I need to feed these two uploading files.

make sure you use the root of your site collection when you open the scope and for the file the path would be something like: /sites/subsitename/MyDocLibraryName/Test_FromClientOM.txt

image

I think I’m actually missing the point here what to copy to scope, item url and local path.

thank you for replies!

in the scope you go only https://…/RPAtestingplatform
for the item URL you do like: /sites/RPAtestingplatform/Shared Documents/ (or maybe you need to go all the way to the filename)

scope is always the same as the local path.
https://jamkstudent.sharepoint.com/sites/RPAtestingplatform/

item url
https://jamkstudent.sharepoint.com/sites/RPAtestingplatform/Shared%20Documents/Forms/AllItems.aspx

Sharepoint application scope: The remote server returned an error: (409) Conflict.

“/sites/RPAtestingplatform/Shared Documents/”

Sharepoint application scope: File Not Found.
(The file still uploaded)

/sites/RPAtestingplatform/Shared Documents/01-30-2020tiedot.xlsx(the file I wanted to move)"

worked out, no problem!

I had another issue though, the upload file wasn’t inside sharepoint application scope.

But problem solved. Big and many thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.