Upload file is keep on giving faulted

Continuing the discussion from SharePoint custom activities documentation not available:

Upload file activity from SharePoint custom activity is suddenly not working. Giving faulted error.

Could you please give us more information about the error and parameters that are triggering it?
Some screenshots will be of great help too. Also, if the error is happening all of a sudden and before this activity worked previosuly I would suggest analyzing the input arguments and/or maybe any recent changes that happened to the project

I will tell my issue scenario.

I have created a SharePoint link and Bot uploaded few set of files in one Path.
By next day, Bot runs and completes the flow and try to upload that specific day files in the same path and throws error.

error: Cannot invoke HTTP DAV request. There is a pending query.

When i try to understand this error, i come to know, the error get triggered, after an error, at the time of file upload, the DAV file resource is still locked from our previous attempt.

So, does this happen when you try to overwrite the file?
If yes, is it possible that this happens because the file is not checked in?

Additionally, @Diana_Mincu and I will try to do some research on that particular error message and we’ll let you know, if we come up with any conclusions


do you have found solution for this issue?


@Diana_Mincu @radu_bucur

Try post checking property “CheckoutFileBeforeOverwrite”

1 Like

Hi @radu_bucur,

When my share point UploadFile activity failed with “Cannot invoke HTTP DAV request. There is a pending query.” error message, I downgraded the version of the package of UiPathTeam.SharePoint.Activities from 1.5.2 to 1.3.0, I was no longer was getting the error and successfully able to upload a file.


Thanks! Had the same problem and downgrading back to 1.3.0 solved it! You saved me alot of time trying to troubleshoot this…

1 Like

Hey guys, we will prepare a fix for this, but in the mean time, I think 1.3.0 is a viable workaround

1 Like

Hi guys,
Could you please test out the attached version and let us know if you still receive the same error? UiPathTeam.SharePoint.Activities.1.5.3.nupkg (108.1 KB)
Thank you

yes still getting same issue

This worked for me and using 1.5.2 :slight_smile:

Hi, I’m having the samen issue. There is a new release with this issue fixed?

Hi Community;
I’m using SharePoint Activities 1.5.2 and I’m having the same error message: Upload file: Cannot invoke HTTP DAV request. There is a pending query.
I will tried using 1.5.3


I’m facing a new issue with this new package RemoteException wrapping System.Net.WebException: The remote server returned an error: (409) Conflict.


I have the same consistant error with 1.5.2. Rollback to 1.3.0 and no issue.

First try (with less uploads) went fine. Publishing directly from Studio to Orchestrator, 1.5.3 produced an exception. I fall back to 1.3.0.

Reason: Impossible de créer le type inconnu ‘{clr-namespace:UiPathTeam.SharePoint.Activities;assembly=UiPathTeam.SharePoint.Activities}SharepointApplicationScope’.

1 Like

Even I tried to degrade the version, but still receiving the same issue.

This works for me too, THANKS :blush:

1 Like